天天看点

poj 1159 Palindrome(最长公共子序列)

Palindrome

Time Limit: 3000MS Memory Limit: 65536K

Total Submissions: 53898 Accepted: 18618

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5

Ab3bd

Sample Output

2

Source

IOI 2000

*/

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
using namespace std;
int dp[10][5001];
int s1[5001];
int s2[5001];
int main()
{
  int n;
  while(~scanf("%d",&n))
  {
  int i,j;
  char ch;
  getchar();
  memset(dp,0,sizeof(dp));
  memset(s1,0,sizeof(s1));
  memset(s2,0,sizeof(s2));
  for(i=1;i<=n;i++)
  {
   scanf("%c",&ch);
   s1[i]=ch;
   s2[n+1-i]=ch;
}
  dp[0][1]=dp[0][0]=0; 
  for(i=0;i<=n;i++)
  dp[0][i]=0;

for(i=1;i<=n;i++)
 for(j=1;j<=n;j++)
 {
if(s1[i]==s2[j])
   dp[i%2][j]=dp[(i-1)%2][j-1]+1;//此处用dp[i][j]总是超内存 
   else
     dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
 }
 printf("%d\n",n-dp[n%2][n]);
  }
  return 0;
} 
           

继续阅读