天天看点

浙大 PAT Advanced level 1011. World Cup Betting

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

For example, 3 games' odds are given as the following:

W T L

1.1 2.5 1.7

1.2 3.0 1.6

4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

Input

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

Sample Input

1.1 2.5 1.7

1.2 3.0 1.6

4.1 1.2 1.1

Sample Output

T T W 37.98

虽然题目描述很复杂,但是实际做起来很简单,唯一需要考虑的是最后输入的结果要用“四舍五入”的方式保留两位小数。

其实标准输出printf 或者 cout 在输出指定小数位数的float类型数字时,会自动进行四舍五入,没必要自己进行四舍五入。

题目的测试用例可能给的不是特别标准,我下面这段代码,可以全部AC,然后输入sample,输出为“37.97”

按照我的经验,PAT中涉及到小数,特别是输出的时候保留2位小数,一般用float类型都不会有什么问题。

#include <iostream>
#include <iomanip>
#include <cstdio>
using namespace std;

int main()
{
	float game[3][3];
	int choice[3];
	float result = 1;
	int temp = 0;

	for (int i = 0; i != 3; ++i)
	{
		int index = 0;
		for (int j = 0; j != 3; ++j)
		{
			cin >> game[i][j];
			if (game[i][j] > game[i][index])
			{
				index = j;
			}
		}
		choice[i] = index;
	}
	for (int i = 0; i != 3; ++i)
	{
		result *= game[i][choice[i]];
		switch(choice[i])
		{
		case 0:
			cout << "W ";
			break;
		case 1:
			cout << "T ";
			break;
		case 2:
			cout << "L ";
			break;
		default:
			system("pause");
			return -1;
		}
	}
	result = (result*0.65-1)*2;
#if 0
	/* 虽然不添加下面这些代码,测试sample的输出为37.97而不是37.98,但是并不影响AC*/
	/* 标准输出printf 或者 cout 在输出指定小数位数的float类型数字时,会自动进行四舍五入*/
	/* sample可能给的不标准*/
	temp = int(result*100);

	//* 处理精度损失的问题, 并进行四舍五入*/
	if(result-temp*0.01 >= 0.004999999)
	{
		result += 0.005000001;
	}
#endif 
	cout << fixed << setprecision(2) << result << endl;
	system("pause");
	return 0;
}