天天看点

poj 2140 Herd Sums 判断S由连续的自然数组成共有几种情况

Herd Sums

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 11551 Accepted: 6891

Description

The cows in farmer John's herd are numbered and branded with consecutive integers from 1 to N (1 <= N <= 10,000,000). When the cows come to the barn for milking, they always come in sequential order from 1 to N. 

Farmer John, who majored in mathematics in college and loves numbers, often looks for patterns. He has noticed that when he has exactly 15 cows in his herd, there are precisely four ways that the numbers on any set of one or more consecutive cows can add up to 15 (the same as the total number of cows). They are: 15, 7+8, 4+5+6, and 1+2+3+4+5. 

When the number of cows in the herd is 10, the number of ways he can sum consecutive cows and get 10 drops to 2: namely 1+2+3+4 and 10. 

Write a program that will compute the number of ways farmer John can sum the numbers on consecutive cows to equal N. Do not use precomputation to solve this problem. 

Input

* Line 1: A single integer: N 

Output

* Line 1: A single integer that is the number of ways consecutive cow brands can sum to N. 

Sample Input

15
      

Sample Output

4      
#include<iostream>
#include<cstdio>
#include<cmath>
using namespace std;
//2*S=n*(2*a1+n-1)
//S=n*(a1+an)/2 ,又因为是连续的,故n和a1+an必然是一奇一偶;
int main()
{
    int n;
    while(scanf("%d",&n)==1)
    {
        int cnt=0;
        double k=sqrt(2*n+0.5);
        for(int i=1;i<=k;i++)//枚举n
        {
            if(2*n%i==0&&((i&1)||(2*n/i)&1))
            {
                int a1=2*n/i-i+1;//计算a1 判断是否符合条件
                if(a1>=0) cnt++;
            }
        }
        printf("%d/n",cnt);
    }
    return 0;
}