天天看点

PAT 1048 Find Coins 散列/双指针

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 10​5​​ coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (≤10​5​​, the total number of coins) and M (≤10​3​​, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the two face values V​1​​ and V​2​​ (separated by a space) such that V​1​​+V​2​​=M and V​1​​≤V​2​​. If such a solution is not unique, output the one with the smallest V​1​​. If there is no solution, output 

No Solution

 instead.

Sample Input 1:

8 15
1 2 8 7 2 4 11 15
           

Sample Output 1:

4 11
           

Sample Input 2:

7 14
1 8 7 2 4 11 15
           

Sample Output 2:

No Solution
           

和LeetCode第一题相似

散列:哈希表记录各数字出现次数,然后从小到大遍历,若i和money-i同时存在,则为最小的结果。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Arrays;

public class Main {

	
    public static void main(String[] args) throws IOException {
    	BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));

    	String[] line1=reader.readLine().split(" ");
    	int N=Integer.valueOf(line1[0]),money=Integer.valueOf(line1[1]);
    	int[] hashTable=new int[1005];//记录各数字出现次数
    	line1=reader.readLine().split(" ");
    	for(int i=0;i<line1.length;i++) {
    		int x=Integer.valueOf(line1[i]);
    		hashTable[x]++;
    	}
    	for(int i=0;i<N;i++) {
    		if(hashTable[i]>0&&hashTable[money-i]>0) {//硬币i和money-i都有
    			if(i==money-i&&hashTable[i]<2)//币值相同,个数不能小于2
    				continue;
    			System.out.println(i+" "+(money-i));
    			return;
    		}
    	}
    	System.out.println("No Solution");
    }
}
           

双指针:先对数组排序,然后首尾两指针判断两处数字和是否等于给定值,等于则为所求答案,否则移动指针,直到i==j时得出没有符合条件的结果。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.ArrayList;
import java.util.Arrays;

public class Main {
	
    public static void main(String[] args) throws IOException {
    	BufferedReader reader=new BufferedReader(new InputStreamReader(System.in));

    	String[] line1=reader.readLine().split(" ");
    	int N=Integer.valueOf(line1[0]),money=Integer.valueOf(line1[1]);
    	int[] num=new int[N];
    	int[] hashTable=new int[1005];//记录各数字出现次数
    	line1=reader.readLine().split(" ");
    	for(int i=0;i<line1.length;i++) {
    		num[i]=Integer.valueOf(line1[i]);
    	}
    	Arrays.sort(num);
    	int i=0,j=N-1;//首尾双指针
    	while(i<j) {
    		if(num[i]+num[j]==money)
    			break;
    		else if(num[i]+num[j]<money)
    			i++;
    		else
    			j--;
    	}
    	if(i==j)
    		System.out.println("No Solution");
    	else
    		System.out.println(num[i]+" "+num[j]);
    }
}
           

继续阅读