天天看点

HDU - 4937 Lucky Number

Problem Description “Ladies and Gentlemen, It’s show time! ”

“A thief is a creative artist who takes his prey in style... But a detective is nothing more than a critic, who follows our footsteps...”

Love_Kid is crazy about Kaito Kid , he think 3(because 3 is the sum of 1 and 2), 4, 5, 6 are his lucky numbers and all others are not.

Now he finds out a way that he can represent a number through decimal representation in another numeral system to get a number only contain 3, 4, 5, 6.

For example, given a number 19, you can represent it as 34 with base 5, so we can call 5 is a lucky base for number 19.

Now he will give you a long number n(1<=n<=1e12), please help him to find out how many lucky bases for that number.

If there are infinite such base, just print out -1.  

Input There are multiply test cases.

The first line contains an integer T(T<=200), indicates the number of cases.

For every test case, there is a number n indicates the number.  

Output For each test case, output “Case #k: ”first, k is the case number, from 1 to T , then, output a line with one integer, the answer to the query.  

Sample Input

2
10
19
        

Sample Output

Case #1: 0
Case #2: 1


  
   
    Hint
   10 shown in hexadecimal number system is another letter different from ‘0’-‘9’, we can represent it as ‘A’, and you can extend to other cases

   
        
HDU - 4937 Lucky Number
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
typedef __int64 ll;
using namespace std;

ll n, ans;

int main() {
	int t, cas = 1;
	scanf("%d", &t);
	while (t--) {
		scanf("%I64d", &n);
		if (n >= 3 && n <= 6) {
			printf("Case #%d: -1\n", cas++);
			continue;
		}
		ans = 0;
		for (ll i = 3; i <= 6; i++)
			for (ll j = 3; j <= 6; j++)
				if ((n-j)%i == 0 && (n-j)/i > max(i, j))
					ans++;
		for (ll i = 3; i <= 6; i++)
			for (ll j = 3; j <= 6; j++)
				for (ll k = 3; k <= 6; k++) {
					ll a = i, b = j, c = k - n;
					ll tmp = (ll) sqrt(b*b - 4*a*c + 0.5);
					if (tmp*tmp != b*b - 4*a*c)
						continue;
					if ((tmp-b)%(2*a) != 0)
						continue;
					ll cnt = (tmp-b)/(2*a);
					if (cnt > max(max(i, j), k))
						ans++;
				}
		for (ll i = 2; i*i*i <= n; i++) {
			ll tmp = n;
			while (tmp) {
				if (tmp % i < 3 || tmp % i > 6)
					break;
				tmp /= i;
			}
			if (tmp == 0)
				ans++;
		}
		printf("Case #%d: %I64d\n", cas++, ans);
	}
	return 0;
}