天天看点

POJ1523解题报告 求点割集

SPF

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 2082 Accepted: 932

Description

Consider the two networks shown below. Assuming that data moves around these networks only between directly connected nodes on a peer-to-peer basis, a failure of a single node, 3, in the network on the left would prevent some of the still available nodes from communicating with each other. Nodes 1 and 2 could still communicate with each other as could nodes 4 and 5, but communication between any other pairs of nodes would no longer be possible.

Node 3 is therefore a Single Point of Failure (SPF) for this network. Strictly, an SPF will be defined as any node that, if unavailable, would prevent at least one pair of available nodes from being able to communicate on what was previously a fully connected network. Note that the network on the right has no such node; there is no SPF in the network. At least two machines must fail before there are any pairs of available nodes which cannot communicate.

POJ1523解题报告 求点割集

Input

The input will contain the description of several networks. A network description will consist of pairs of integers, one pair per line, that identify connected nodes. Ordering of the pairs is irrelevant; 1 2 and 2 1 specify the same connection. All node numbers will range from 1 to 1000. A line containing a single zero ends the list of connected nodes. An empty network description flags the end of the input. Blank lines in the input file should be ignored.

Output

For each network in the input, you will output its number in the file, followed by a list of any SPF nodes that exist.

The first network in the file should be identified as "Network #1", the second as "Network #2", etc. For each SPF node, output a line, formatted as shown in the examples below, that identifies the node and the number of fully connected subnets that remain when that node fails. If the network has no SPF nodes, simply output the text "No SPF nodes" instead of a list of SPF nodes.

Sample Input

1 2
5 4
3 1
3 2
3 4
3 5
0

1 2
2 3
3 4
4 5
5 1
0

1 2
2 3
3 4
4 6
6 3
2 5
5 1
0

0      

Sample Output

Network #1
  SPF node 3 leaves 2 subnets

Network #2
  No SPF nodes

Network #3
  SPF node 2 leaves 2 subnets
  SPF node 3 leaves 2 subnets      
题目大意:给定一个连通的计算机网络(就是一无向图)中的每条边,求要想使网络中断,可以中断哪台计算器的网络,输出中断的计算机编号      
并输出中断那台计算机后网络被分成了几块?      
我的点割集第一题      
思路:典型的求点割集问题,直接把刚才写的求点割集算法代码拿来改改就交了,一次AC,需要注意的是,在统计去掉割点后的连通分      
支可以直接用count,如果是DFS根节点则为count,否则为count+1。。      
#include<iostream>
using namespace std;

struct L
{
	int v;	L *next;
};


L * head[1000];  int dfn[1000],low[1000],t,O,out[1000];     bool lock[1000],C[1000];


void find(int father,int v)
{
    int count=0;		
	dfn[v]=low[v]=++t;    
	lock[v]=false;   
	for(L *p=head[v];p!=NULL;p=p->next)
	{
		if(lock[p->v])  
		{
			find(v,p->v); 
			count++;        
			if(low[v]>low[p->v])  
				low[v]=low[p->v];
			
			if(!father&&count>1)
			{
				C[v]=true;
				out[v]=count;
			}
			else if(father&&dfn[v]<=low[p->v])  
			{
				C[v]=true;
				out[v]=count+1;
			}
			
		}
		else if(p->v!=father&&low[p->v]<low[v])  
			low[v]=low[p->v];
		
	}
}


int main()
{
	int n,i,a,b,d=1;
	while(cin>>a&&a)
	{
		memset(head,0,sizeof(int)*1000);
		cin>>b;
		L *p=new L;
		p->next=head[b];
		head[b]=p;
		p->v=a;
		p=new L;
		p->next=head[a];
		head[a]=p;
		p->v=b;
		while(cin>>a&&a&&cin>>b)		
		{
			L *p=new L;
			p->next=head[b];
			head[b]=p;
			p->v=a;
			p=new L;
			p->next=head[a];
			head[a]=p;
			p->v=b;
		}
		memset(lock,true,sizeof(lock));
		memset(dfn,0,sizeof(int)*1000);
		memset(C,0,sizeof(C));  
		t=0;
		find(0,1);
		cout<<"Network #"<<d++<<endl;
		for(i=1,O=0;i<1000;i++)	
			if(C[i]&&++O)
		    	  cout<<"  SPF node "<<i<<" leaves "<<out[i]<<" subnets"<<endl;

		if(!O)
			cout<<"  No SPF nodes"<<endl;
		cout<<endl;
	}
}
       

继续阅读