天天看點

HDU 3466 Proud Merchants

Description

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 

The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 

If he had M units of money, what’s the maximum value iSea could get? 

Input

There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 

Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 

Output

For each test case, output one integer, indicating maximum value iSea could get. 

Sample Input

2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3      

Sample Output

5

11

背包問題,多了一個限制,排序即可。

一開始考慮按照Qi從小到大排序,wa了,後來改為Qi-Pi就ok了

#include<set>
#include<map>
#include<ctime>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
#define loop(i,j,k) for (int i = j;i != -1; i = k[i])
#define lson x << 1, l, mid
#define rson x << 1 | 1, mid + 1, r
#define fi first
#define se second
#define mp(i,j) make_pair(i,j)
#define pii pair<string,string>
using namespace std;
typedef long long LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e5 + 10;
const int read()
{
  char ch = getchar();
  while (ch<'0' || ch>'9') ch = getchar();
  int x = ch - '0';
  while ((ch = getchar()) >= '0'&&ch <= '9') x = x * 10 + ch - '0';
  return x;
}
int T, n, m, f[N];

struct point
{
  int x, y, z;
  void read() { scanf("%d%d%d", &x, &y, &z); }
  bool operator<(const point&a)const
  {
    return y - x < a.y - a.x;
  }
}a[N];

int main()
{
  //T = read();
  while (scanf("%d%d", &n, &m) != EOF)
  {
    rep(i, 1, n) a[i].read();
    sort(a + 1, a + n + 1);
    rep(i, 0, m) f[i] = 0;
    rep(i, 1, n) per(j, m, a[i].y) 
      f[j] = max(f[j], f[j - a[i].x] + a[i].z);
    printf("%d\n", f[m]);
  } 
  return 0;
}