天天看點

PAT (Advanced Level) Practise 1121 Damn Single (25)

1121. Damn Single (25)

時間限制

300 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

"Damn Single (單身狗)" is the Chinese nickname for someone who is being single. You are supposed to find those who are alone in a big party, so they can be taken care of.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=50000), the total number of couples. Then N lines of the couples follow, each gives a couple of ID's which are 5-digit numbers (i.e. from 00000 to 99999). After the list of couples, there is a positive integer M (<=10000) followed by M ID's of the party guests. The numbers are separated by spaces. It is guaranteed that nobody is having bigamous marriage (重婚) or dangling with more than one companion.

Output Specification:

First print in a line the total number of lonely guests. Then in the next line, print their ID's in increasing order. The numbers must be separated by exactly 1 space, and there must be no extra space at the end of the line.

Sample Input:

3
11111 22222
33333 44444
55555 66666
7
55555 44444 10000 88888 22222 11111 23333      

Sample Output:

5

10000 23333 44444 55555 88888

#include<cmath>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define lson x<<1,l,mid
#define rson x<<1|1,mid+1,r
const int N = 1e5 + 10;
const int INF = 0x7FFFFFFF;
int n, f[N], x, y;
int a[N], g[N];
int b[N], c;

int main()
{
  inone(n);
  rep(i, 1, n)
  {
    intwo(x, y);
    f[x] = y; f[y] = x;
  }
  inone(n);
  rep(i, 1, n) inone(a[i]), g[a[i]] = 1;
  rep(i, 1, n) if (!g[f[a[i]]]) b[c++] = a[i];
  sort(b, b + c);
  printf("%d\n", c);
  rep(i, 0, c - 1)
  {
    printf("%s%05d", i ? " " : "", b[i]);
  }
  return 0;
}