天天看點

PAT (Advanced Level) Practise 1122 Hamiltonian Cycle (25)

1122. Hamiltonian Cycle (25)

時間限制

300 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2< N <= 200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format "Vertex1 Vertex2", where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V1 V2 ... Vn

where n is the number of vertices in the list, and Vi's are the vertices on a path.

Output Specification:

For each query, print in a line "YES" if the path does form a Hamiltonian cycle, or "NO" if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1      

Sample Output:

YES
NO
NO
NO
YES
NO      

判斷給出的是不是哈密頓回路,根據條件篩選就行,n==N+1并且首尾要向同,并且中間沒有重複的點,并且中間的點要能走。

#include<cmath>
#include<queue>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define ms(x,y) memset(x,y,sizeof(x))
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define loop(i,j,k) for (int i=j;i!=-1;i=k[i])
#define inone(x) scanf("%d",&x)
#define intwo(x,y) scanf("%d%d",&x,&y)
#define inthr(x,y,z) scanf("%d%d%d",&x,&y,&z)
#define lson x<<1,l,mid
#define rson x<<1|1,mid+1,r
const int N = 1e3 + 10;
const int INF = 0x7FFFFFFF;
int n, m, x, y, q;
int f[N][N], a[N * 100], g[N];

int main()
{
  intwo(n, m);
  while (m--)
  {
    intwo(x, y);
    f[x][y] = f[y][x] = 1;
  }
  inone(m);
  while (m--)
  {
    inone(q);
    int flag = q == n + 1;
    rep(i, 1, q) inone(a[i]);
    flag &= a[1] == a[q];
    rep(i, 1, n) g[i] = 0;
    rep(i, 1, q - 1)
    {
      if (g[a[i]]++) flag = 0;
      flag &= f[a[i]][a[i + 1]];
    }
    printf("%s\n", flag ? "YES" : "NO");
  }
  return 0;
}