天天看點

HDU 5280 Senior's Array

Problem Description

A. Among all non-empty intervals of 

A, she wants to find the most beautiful one. She defines the beauty as the sum of the interval. The beauty of the interval---

[L,R] is calculated by this formula : beauty(L,R) = 

A[L]+A[L+1]+……+A[R]. The most beautiful interval is the one with maximum beauty.

But as is known to all, Xuejiejie is used to pursuing perfection. She wants to get a more beautiful interval. So she asks Mini-Sun for help. Mini-Sun is a magician, but he is busy reviewing calculus. So he tells Xuejiejie that he can just help her change one value of the element of 

A to 

P . Xuejiejie plans to come to see him in tomorrow morning.

Unluckily, Xuejiejie oversleeps. Now up to you to help her make the decision which one should be changed(You must change one element).

Input

T, indicates the number of test cases.

In each case, the first line contains two integers 

n and 

P. 

n means the number of elements of the array. 

P means the value Mini-Sun can change to. 

The next line contains the original array.

1≤n≤1000, 

−109≤A[i],P≤109。

Output

For each test case, output one integer which means the most beautiful interval's beauty after your change.

Sample Input

2
3 5
1 -1 2
3 -2
1 -1 2      

Sample Output

8

2

#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<vector>
#include<set>
#include<map>
#include<queue>
using namespace std;
const int maxn = 100005;
int n, m, T;
__int64 f[maxn], a[maxn], p, ans;

int main()
{
    scanf("%d", &T);
    while (T--)
    {
        scanf("%d%I64d", &n, &p);
        for (int i = 1; i <= n; i++) scanf("%I64d", &a[i]);
        ans = a[1];
        for (int i = 1; i <= n; i++)
        {
            int t = a[i];    a[i] = p;    f[1] = a[1];
            ans = max(f[1], ans);
            for (int j = 2; j <= n; j++)
            {
                f[j] = max(a[j], f[j - 1] + a[j]);
                ans = max(f[j], ans);
            }
            a[i] = t;
        }
        printf("%I64d\n", ans);
    }
    return 0;
}