1038. Recover the Smallest Number (30)
時間限制
400 ms
記憶體限制
65536 kB
代碼長度限制
16000 B
判題程式
Standard
作者
CHEN, Yue
Given a collection of number segments, you are supposed to recover the smallest number from them. For example, given {32, 321, 3214, 0229, 87}, we can recover many numbers such like 32-321-3214-0229-87 or 0229-32-87-321-3214 with respect to different orders of combinations of these segments, and the smallest number is 0229-321-3214-32-87.
Input Specification:
Each input file contains one test case. Each case gives a positive integer N (<=10000) followed by N number segments. Each segment contains a non-negative integer of no more than 8 digits. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the smallest number in one line. Do not output leading zeros.
Sample Input:
5 32 321 3214 0229 87
Sample Output:
22932132143287
排個序,去掉前導零就好了。排序的關鍵是a+b<b+a
#include<cstdio>
#include<string>
#include<stack>
#include<vector>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
const int maxn = 1e5 + 10;
typedef long long LL;
int n;
string s[maxn];
bool cmp(const string& a, const string& b)
{
return a + b < b + a;
}
int main()
{
scanf("%d", &n);
for (int i = 0; i < n; i++) cin >> s[i];
sort(s, s + n, cmp);
int flag = 1;
for (int i = 0; i < n; i++)
{
for (int j = 0; s[i][j]; j++)
{
if (flag&&s[i][j] == '0') continue;
flag = 0; printf("%c", s[i][j]);
}
}
if (flag) printf("0\n");
return 0;
}