天天看點

PAT (Advanced Level) Practise 1112 Stucked Keyboard (20)

1112. Stucked Keyboard (20)

時間限制

400 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

On a broken keyboard, some of the keys are always stucked. So when you type some sentences, the characters corresponding to those keys will appear repeatedly on screen for k times.

Now given a resulting string on screen, you are supposed to list all the possible stucked keys, and the original string.

Notice that there might be some characters that are typed repeatedly. The stucked key will always repeat output for a fixed k times whenever it is pressed. For example, when k=3, from the string "thiiis iiisss a teeeeeest" we know that the keys "i" and "e" might be stucked, but "s" is not even though it appears repeatedly sometimes. The original string could be "this isss a teest".

Input Specification:

Each input file contains one test case. For each case, the 1st line gives a positive integer k ( 1<k<=100 ) which is the output repeating times of a stucked key. The 2nd line contains the resulting string on screen, which consists of no more than 1000 characters from {a-z}, {0-9} and "_". It is guaranteed that the string is non-empty.

Output Specification:

For each test case, print in one line the possible stucked keys, in the order of being detected. Make sure that each key is printed once only. Then in the next line print the original string. It is guaranteed that there is at least one stucked key.

Sample Input:

3

caseee1__thiiis_iiisss_a_teeeeeest

Sample Output:

ei

case1__this_isss_a_teest

#include<cstdio>
#include<vector>
#include<queue>
#include<string>
#include<map>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int INF = 0x7FFFFFFF;
const int maxn = 1e5 + 10;
int n, flag[maxn];
char s[maxn];

int main()
{
  scanf("%d%s", &n, s);
  for (int i = 0, j = 0; s[i]; i = j)
  {
    while (s[j] && s[i] == s[j]) j++;
    if ((j - i) % n) flag[s[i]] = -1;
    else if (!flag[s[i]]) flag[s[i]] = 1;
  }
  for (int i = 0; s[i]; i++)
  {
    if (flag[s[i]] == 1)
    {
      printf("%c", s[i]);
      flag[s[i]] = 2;
    }
  }
  printf("\n");
  for (int i = 0; s[i]; i++)
  {
    printf("%c", s[i]);
    if (flag[s[i]] == 2) i += n - 1;
  }
  return 0;
}