天天看點

PAT (Advanced Level) Practise 1067 Sort with Swap(0,*) (25)

1067. Sort with Swap(0,*) (25)

時間限制

150 ms

記憶體限制

65536 kB

代碼長度限制

16000 B

判題程式

Standard

作者

CHEN, Yue

Given any permutation of the numbers {0, 1, 2,..., N-1}, it is easy to sort them in increasing order. But what if Swap(0, *) is the ONLY operation that is allowed to use? For example, to sort {4, 0, 2, 1, 3} we may apply the swap operations in the following way:

Swap(0, 1) => {4, 1, 2, 0, 3}

Swap(0, 3) => {4, 1, 2, 3, 0}

Swap(0, 4) => {0, 1, 2, 3, 4}

Now you are asked to find the minimum number of swaps need to sort the given permutation of the first N nonnegative integers.

Input Specification:

Each input file contains one test case, which gives a positive N (<=105) followed by a permutation sequence of {0, 1, ..., N-1}. All the numbers in a line are separated by a space.

Output Specification:

For each case, simply print in a line the minimum number of swaps need to sort the given permutation.

Sample Input:

10 3 5 7 2 6 4 9 0 8 1

Sample Output:

9

暴力瞎跑,如果0不在0位置上,那把0和該放在這個位置的數交換,直到0回到0位置,然後看看有沒有不在自己位置上的,

和0換了,在按照上面的步驟執行就ok了。

#include<cmath>
#include<queue>
#include<string>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
using namespace std;
typedef long long LL;
typedef unsigned long long ull;
const int mod = 1e9 + 7;
const int maxn = 2e5 + 10;
int n, x, a[maxn], cnt, k = 0;

int main()
{
    scanf("%d", &n);
    cnt = 0;
    for (int i = 0; i < n; i++)
    {
        scanf("%d", &x);
        a[x] = i;
    }
    while (true)
    {
        while (a[0] != 0)
        {
            x = a[0];
            cnt++;
            swap(a[x], a[0]);
        }
        for (int i = k; i < n; i++)
        if (a[i] != i)
        {
            swap(a[i], a[0]);
            cnt++;
            k = i;
            break;
        }
        else if (i == n - 1)
        {
            printf("%d\n", cnt);
            return 0;
        }
    }
    return 0;
}