天天看點

HDU 5791 Two

Problem Description

Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.

Input

The input contains multiple test cases.

For each test case, the first line cantains two integers 

N,M(1≤N,M≤1000). The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.

Output

For each test case, output the answer mod 1000000007.

Sample Input

3 2

1 2 3

2 1

3 2

1 2 3

1 2

Sample Output

3

#include<set>
#include<map>
#include<cmath>
#include<stack>
#include<queue>
#include<bitset>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<functional>
#define rep(i,j,k) for (int i = j; i <= k; i++)
#define per(i,j,k) for (int i = j; i >= k; i--)
using namespace std;
typedef __int64 LL;
const int low(int x) { return x&-x; }
const double eps = 1e-8;
const int INF = 0x7FFFFFFF;
const int mod = 1e9 + 7;
const int N = 1e3+ 10;
int T, n, m, dp[N][N], a[N], b[N];
int f[N][N];

int get(int x, int y)
{
    int res = 0;
    for (int i = x; i; i -= low(i))
    {
        for (int j = y; j; j -= low(j))
        {
            (res += f[i][j]) %= mod;
        }
    }
    return res;
}

void insert(int x, int y, int z)
{
    for (int i = x; i <= n; i += low(i))
    {
        for (int j = y; j <= m; j += low(j))
        {
            f[i][j] = (f[i][j] + z) % mod;
        }
    }
}

int main()
{
    //scanf("%d", &T);
    //while (T--)
    while (scanf("%d%d", &n, &m) != EOF)
    {
        rep(i, 1, n) scanf("%d", &a[i]);
        rep(i, 1, m) scanf("%d", &b[i]);
        rep(i, 1, n) rep(j, 1, m) f[i][j] = 0;
        int ans = 0;
        rep(i, 1, n)
        {
            rep(j, 1, m)
            {
                if (a[i] == b[j])
                {
                    dp[i][j] = (1 + get(i - 1, j - 1)) % mod;
                    insert(i, j, dp[i][j]);
                    ans = (ans + dp[i][j]) % mod;
                }
            }
        }
        printf("%d\n", ans);
    }
    return 0;
}