1099. Build A Binary Search Tree (30)
時間限制
100 ms
記憶體限制
65536 kB
代碼長度限制
16000 B
判題程式
Standard
作者
CHEN, Yue
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:
- The left subtree of a node contains only nodes with keys less than the node's key.
- The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
- Given the structure of a binary tree and a sequence of distinct integer keys, there is only one way to fill these keys into the tree so that the resulting tree satisfies the definition of a BST. You are supposed to output the level order traversal sequence of that tree. The sample is illustrated by Figure 1 and 2.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (<=100) which is the total number of nodes in the tree. The next N lines each contains the left and the right children of a node in the format "left_index right_index", provided that the nodes are numbered from 0 to N-1, and 0 is always the root. If one child is missing, then -1 will represent the NULL child pointer. Finally N distinct integer keys are given in the last line.
Output Specification:
- Sample Input:
- Sample Output:
- 按照排序二叉樹的中序周遊把序列從小到大插入,然後bfs輸出。
#include<cstdio>
#include<vector>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn = 1e5 + 10;
int ch[maxn][2], n, v[maxn], a[maxn], t;
void dfs(int x)
{
if (x == -1) return;
dfs(ch[x][0]);
v[x] = a[t++];
dfs(ch[x][1]);
}
int main()
{
scanf("%d", &n);
for (int i = 0; i < n; i++) scanf("%d%d", &ch[i][0], &ch[i][1]);
for (int i = 0; i < n; i++) scanf("%d", &a[i]);
sort(a, a + n);
dfs(0);
queue<int> p;
p.push(0);
while (!p.empty())
{
int q = p.front(); p.pop();
printf("%s%d", q ? " " : "", v[q]);
if (ch[q][0] >= 0) p.push(ch[q][0]);
if (ch[q][1] >= 0) p.push(ch[q][1]);
}
return 0;
}