天天看點

HUST 1544 R(N)

Description

We know that some positive integer x can be expressed as x=A^2+B^2(A,B are integers). Take x=10 for example, 10=(-3)^2+1^2.

We define R(N) (N is positive) to be the total number of variable presentation of N. So R(1)=4, which consists of 1=1^2+0^2, 1=(-1)^2+0^2, 1=0^2+1^2, 1=0^2+(-1)^2.Given N, you are to calculate R(N).

Input

No more than 100 test cases. Each case contains only one integer N(N<=10^9).

Output

For each N, print R(N) in one line.

Sample Input

2

6

10

25

65

Sample Output

4

8

12

16

Hint

For the fourth test case, (A,B) can be (0,5), (0,-5), (5,0), (-5,0), (3,4), (3,-4), (-3,4), (-3,-4), (4,3) , (4,-3), (-4,3), (-4,-3)

#include<string>
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
#include<map>
#include<cmath>
using namespace std;
const int maxn = 10 + 5;
typedef long long LL;
int T, n, m;
map<int, int> M;

int main()
{
  for (int i = 0; i*i <= 1e9; i++)
  {
    M[i*i] = 1;
  }
  while (scanf("%d", &n) != EOF)
  {
    LL ans = 0;
    for (int i = 0; i*i <= n; i++)
    {
      if (M[n - i*i])
      {
        int t = 4;
        if (i == 0) t /= 2;
        if (n == i*i) t /= 2;
        ans += t;
      }
    }
    cout << ans << endl;
  }
  //while (scanf("%d", &n) != EOF){}
  return 0;
}