天天看點

HDU - 3853 LOOPS (期望dp)

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl). 

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS. 

The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)! 

At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power she need to escape from the LOOPS. 

Input

The first line contains two integers R and C (2 <= R, C <= 1000). 

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1, c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces. 

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them). 

You may ignore the last three numbers of the input data. They are printed just for looking neat. 

The answer is ensured no greater than 1000000. 

Terminal at EOF 

Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS. 

Sample Input

2 2

0.00 0.50 0.50 0.50 0.00 0.50

0.50 0.50 0.00 1.00 0.00 0.00

Sample Output

6.000

題目大概:

有一個n*m的矩陣,有個人想要從(1,1)從到達(n,m)。每次走一個花費2分鐘。

每次從位置(i,j)走到(i,j+1),(i+1,j)或者停留在原地,都有一個機率。三者相加為1.

問最後到達(n,m)的期望時間。

思路:

dp[i][j]表示到了位置(i,j),距離到(n,m)還差的期望。

l[i][j]表示停留原地的機率,d[i][j]表示向下走的機率,r[i][j]表示向右走的機率。

得到逆推公式

dp[i][j]=l[i][j]*dp[i][j]+d[i][j]*dp[i+1][j]+r[i][j]*dp[i][j+1]+2.

化簡的dp[i][j]=(+d[i][j]*dp[i+1][j]+r[i][j]*dp[i][j+1]+2)/(1-l[i][j]).

#include <bits/stdc++.h>

using namespace std;
#define ll long long
const int maxn=1e3+10;
double t[maxn][maxn];
double l[maxn][maxn],d[maxn][maxn];
double dp[maxn][maxn];
int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%lf%lf%lf",&t[i][j],&l[i][j],&d[i][j]);
            }
        }
        for(int i=n;i>=1;i--)
        {
            for(int j=m;j>=1;j--)
            {
                if(i==n&&j==m)continue;
                double p=1-t[i][j];
                if(p<1e-7)continue;
                dp[i][j]=(l[i][j]*dp[i][j+1]+d[i][j]*dp[i+1][j]+2)/p;

            }
        }
        printf("%.3lf\n",dp[1][1]);
    }
    return 0;
}