天天看點

POJ P1988 Cube Stacking 并查集

Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 17018 Accepted: 5862
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 

moves and counts. 

* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 

* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a 'M' for a move operation or a 'C' for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4
      
Sample Output
1
0
2
      

Source

USACO 2004 U S Open

其實這道題和銀河英雄傳說非常像。。。

附我百度來的題目翻譯:

題目大意:

一開始有N個标号為1到N的立方體,它們各成一堆,給出兩種操作:

1.M X Y :将X所在的堆疊在Y所在的堆上面,保證X和Y不在同一堆。

2.C X :計算在X所在的堆中在X下方的有多少立方塊,并輸出。

輸入:

第一行輸入P,表示下面有多少個操作

第2到p+1行,每行輸入一個操作,或M X Y或C X

輸出:

當有C X操作時輸出

快2點了。。poj還有那麼多人在刷題,,,

#include <iostream>
using namespace std;

int set[30010],count[30010],before[30010];
int i,n,x,y,fx,fy;
string s;

int FindSet(int x);
void Union(int x,int y);
int main()
{
	ios::sync_with_stdio(false);
	for (i=1;i<30010;++i){
		set[i]=i;
		count[i]=1;
		before[i]=0;
	}
	cin>>n;
	while (n--){
		cin>>s;
		if (s == "M"){
			cin>>x>>y;
			Union(x,y);
		}else{
			cin>>x;
			FindSet(x);
			cout<<before[x]<<endl;
		}
	}
	return 0;
}

int FindSet(int x){
	if (set[x] != x){
		int temp=set[x];
		set[x]=FindSet(set[x]);
		count[x]=count[temp];
		before[x]+=before[temp];
	}
	return set[x];
}

void Union(int x,int y){
	int fx=FindSet(x);
	int fy=FindSet(y);
	set[fx]=fy;
	before[fx]=count[fy];
	count[fy]+=count[fx];
	return;
}
           

kdwycz的網站:  http://kdwycz.com/

kdwyz的刷題空間:http://blog.csdn.net/kdwycz