天天看點

Wet Shark and Bishops

  Wet Shark and Bishops

Time Limit:2000MS     Memory Limit:262144KB     64bit IO Format:%I64d & %I64u

Submit Status

Description

Today, Wet Shark is given n bishops on a 1000 by 1000 grid. Both rows and columns of the grid are numbered from 1 to 1000. Rows are numbered from top to bottom, while columns are numbered from left to right.

Wet Shark thinks that two bishops attack each other if they share the same diagonal. Note, that this is the only criteria, so two bishops may attack each other (according to Wet Shark) even if there is another bishop located between them. Now Wet Shark wants to count the number of pairs of bishops that attack each other.

Input

The first line of the input containsn (1 ≤ n ≤ 200 000) — the number of bishops.

Each of next n lines contains two space separated integers xi and yi (1 ≤ xi, yi ≤ 1000) — the number of row and the number of column wherei-th bishop is positioned. It's guaranteed that no two bishops share the same position.

Output

Output one integer — the number of pairs of bishops which attack each other.

Sample Input

Input

5
1 1
1 5
3 3
5 1
5 5
      

Output

6      

Input

3
1 1
2 3
3 5
      

Output

Sample Output

Hint

In the first sample following pairs of bishops attack each other:(1, 3), (1, 5), (2, 3), (2, 4), (3, 4) and(3, 5). Pairs (1, 2),(1, 4), (2, 5) and (4, 5) do not attack each other because they do not share the same diagonal.

題意:一個1000*1000的棋盤,給你N個點的坐标,問有多少對點在對角線上。

思路:找出對角線上有多少點,再求C(n,2)即可。

規律:斜向右下的一條|x-y|都相等,斜向左下的一條x+y都相等,求出線上個數。注:相同結果存入一個a[i],個數為a[i]++,

代碼如下:

#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int a[2100],b[2100];
int main() 
{
   int x,y,n;
  while(scanf("%d",&n)!=EOF)
  {
  memset(a,0,sizeof(a));
  memset(b,0,sizeof(b));
  long long ans=0;
  for(int i=1;i<=n;i++)
  {
   scanf("%d%d",&x,&y);
   a[x-y+1000]++;
   b[x+y]++;
  }
  for(int i=1;i<=2000;i++)
  {
   if(a[i]!=0)
   {
    ans+=a[i]*(a[i]-1)/2;
   }
   if(b[i]!=0)
   {
    ans+=b[i]*(b[i]-1)/2;
   }
  }
  printf("%lld\n",ans);
 }
 return 0;
}