天天看點

【spfa(棧)||堆優dijkstra】poj3159

Candies

Description

During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.

snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?

Input

The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 throughN. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid A believed that kid B should never get over c candies more than he did.

Output

Output one line with only the largest difference desired. The difference is guaranteed to be finite.

Sample Input

2 2
1 2 5
2 1 4      

Sample Output

5      
差分限制,雖然還沒看到那兒,但是高中講過畢竟有點點印象,是以還是構造出來了      
但是用spfa會逾時(priority_queue和手工循環隊列都會tle)然後看了poj的discuss說是可以用棧……這個道理都差不多但是确實是想不到這麼幹      
當然還可以用堆優的dijkstra      
spfa(棧):      
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;;
const long N =  30010, M = 150010, Q = N * 2;
const long INF = 0x3f3f3f3f;
struct ty
{
    long t, w, next;
};
long n, t, m;
long head[N];
ty edge[M];
long q[Q];
bool v[N];
long dist[N];
void insertedge(long x, long y, long z, long k)
{
    edge[k].t = y;
    edge[k].w = z;
    edge[k].next = head[x];
    head[x] = k;
}
void init()
{
    memset(head, 0, sizeof(head));
    memset(edge, 0, sizeof(edge));
    m = 0;
    for (long i = 1; i <= t; i++)
    {
        long x, y, z;
        scanf("%d%d%d", &x, &y, &z);
        insertedge(x, y, z, ++m);
    }
}
void spfa()
{
    memset(v, 0, sizeof(v));
    memset(dist, 127, sizeof(dist));
    long  r = 0;
    q[++r] = 1;
    v[1] = true;
    dist[1] = 0;
    while (r)
    {
        long x = q[r--];
        v[x] = false;
        for (long i = head[x]; i != 0; i = edge[i].next)
        {
            long t = edge[i].t;
            if (dist[t] > dist[x] + edge[i].w)
            {
                dist[t] = dist[x] + edge[i].w;
                if (!v[t])
                {
                    q[++r] = t;
                    v[t] = true;
                }
            }
        }
    }
    cout << dist[n] << endl;
}
int main()
{
    while(scanf("%d%d", &n, &t) != EOF)
    {
        init();
        spfa();
    }
    return 0 ;
}
           
堆優dijkstra:      
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
using namespace std;;
const long N =  30010, M = 150010, Q = N * 2;
const long INF = 0x3f3f3f3f;
struct ty
{
    long t, w, next;
    bool operator < (const ty &a) const
    {
        if (w > a.w) return true;
			else return false;
    }
};
priority_queue<ty> q;
long n, t, m;
long head[N];
ty edge[M];
bool v[N];
long dist[N];
void insertedge(long x, long y, long z, long k)
{
    edge[k].t = y;
    edge[k].w = z;
    edge[k].next = head[x];
    head[x] = k;
}
void init()
{
    memset(head, 0, sizeof(head));
    memset(edge, 0, sizeof(edge));
    m = 0;
    for (long i = 1; i <= t; i++)
    {
        long x, y, z;
        scanf("%d%d%d", &x, &y, &z);
        insertedge(x, y, z, ++m);
    }
}
void dijkstra_priority_queue()
{
    memset(v, 0, sizeof(v));
    memset(dist, 127, sizeof(dist));
    v[1]=true;
    dist[1]=0;
    for (long i = head[1]; i != 0; i = edge[i].next)
    {
        if (edge[i].w < dist[edge[i].t])
        {
            dist[edge[i].t] = edge[i].w;
            q.push(edge[i]);
        }

    }
    ty t1, t2;
    while(!q.empty() )
    {
        t1 = q.top();
        q.pop();
        if (v[t1.t]) continue;
        v[t1.t] = true;
        for (long j = head[t1.t]; j != 0; j = edge[j].next)
        {
            long u = edge[j].t;
            if ((!v[u]) && (dist[u] > edge[j].w + dist[t1.t]))
            {
                dist[u] = edge[j].w + dist[t1.t];
                t2.t = u;
                t2.w = dist[u];
                q.push(t2);
            }
        }
    }

    cout << dist[n] << endl;
}
int main()
{
    while(scanf("%d%d", &n, &t) != EOF)
    {
        init();
        dijkstra_priority_queue();
    }
    return 0 ;
}