天天看點

hdu2955 Robberies 01背包的變形

感覺網上的這個題解比答案給的好多了,至少人家想到了用01背包變形->_->把錢的總和想象成包的容量,容量最多也就是sum嘛~

然後先不考慮機率是否夠,遞推結束後從大數向小數查找 滿足機率就輸出即是解

本來以為想明白了就沒事了,還有一個梗是dp數組最大應該是錢數總和,是以數組不能開小了,就因為這RE了好多次,這要是比賽不還的後悔死啊—>_—>還是欠練

再就是為了保險起見還是max自己寫一個吧~~總的來說就是注意細節

Problem Description The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university.

hdu2955 Robberies 01背包的變形

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.

His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.  

Input The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .

Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .  

Output For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.

Notes and Constraints

0 < T <= 100

0.0 <= P <= 1.0

0 < N <= 100

0 < Mj <= 100

0.0 <= Pj <= 1.0

A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.  

Sample Input

3
0.04 3
1 0.02
2 0.03
3 0.05
0.06 3
2 0.03
2 0.03
3 0.05
0.10 3
1 0.03
2 0.02
3 0.05
        

Sample Output

2
4
6
        
#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
double pj[1050],dp[100500],p,rate;
int t,m[1050],n,sum;
double max(double a,double b)
{
     if(a<b) return b;
     else return a;
}
int main()
{
   // freopen("cin.txt","r",stdin);
    while(~scanf("%d",&t))
    {
         while(t--)
         {
              memset(dp,0,sizeof(dp));
              dp[0]=1;
              sum=0;
              scanf("%lf%d",&p,&n);
              p=1-p;
              for(int i=0;i<n;i++)
              {
                   scanf("%d%lf",&m[i],&pj[i]);
                   pj[i]=1-pj[i];
                   sum+=m[i];
              }
              for(int i=0;i<n;i++)
              {
                   for(int j=sum;j>=m[i];j--)
                    dp[j]=max(dp[j],dp[j-m[i]]*pj[i]);
              }
              for(int i=sum;i>=0;i--)
              {
                   if(dp[i]>p)
                   {
                        printf("%d\n",i);
                        break;
                   }
              }
         }
    }
    return 0;
}