天天看點

BestCoder Round #34 1001 Go to movies

Go to movies

Time Limit: 1000MS Memory Limit: 65536KB 64bit IO Format: %I64d & %I64u

Submit Status

Description

Winter holiday is coming!As the monitor, LeLe plans to go to the movies. 

Because the winter holiday tickets are pretty expensive, LeLe decideds to try group-buying.  

Input

There are multiple test cases, about $20$ cases. The first line of input contains two integers $n,m(1 \leq n,m \leq 100)$. $n$ indicates the number of the students. $m$ indicates how many cinemas have offered group-buying. 

For the $m$ lines,each line contains two integers $a_i,b_i(1 \leq ai,bi \leq 100)$, indicating the choices of the group buying cinemas offered which means you can use $b_i$ yuan to buy $a_i$ tickets in this cinema.  

Output

For each case, please help LeLe **choose a cinema** which costs the least money. Output the total money LeLe should pay.  

Sample Input

3 2
2 2
3 5 
          

Sample Output

4 
          

Hint

LeLe can buy four tickets with four yuan in cinema 1.
               

Source

BestCoder Round #34

題意:給你n,m分别代表人數和可選擇的電影院,然後m行a b代表b元能買a張票,問你n個人最少需要多少錢。

做法:水題,直接做。

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<vector>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
    int n,m;
    int ans,t,tt;
    int a,b;
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        ans=10000000000;
        for(i=1;i<=m;i++)
        {
            scanf("%d%d",&a,&b);
            t=a;
            tt=b;
            while(n>t)
            {
                t+=a;
                tt+=b;
            }
            ans=min(ans,tt);
        }
        printf("%d\n",ans);
    }
    return 0;
}