天天看點

POJ 2447 Remmarguts' Date【k短路 SPFA+A* 模闆題】

Remmarguts' Date

Time Limit: 4000MS Memory Limit: 65536K
Total Submissions: 26059 Accepted: 7079

Description

"Good man never makes girls wait or breaks an appointment!" said the mandarin duck father. Softly touching his little ducks' head, he told them a story. 

"Prince Remmarguts lives in his kingdom UDF – United Delta of Freedom. One day their neighboring country sent them Princess Uyuw on a diplomatic mission." 

"Erenow, the princess sent Remmarguts a letter, informing him that she would come to the hall and hold commercial talks with UDF if and only if the prince go and meet her via the K-th shortest path. (in fact, Uyuw does not want to come at all)" 

Being interested in the trade development and such a lovely girl, Prince Remmarguts really became enamored. He needs you - the prime minister's help! 

DETAILS: UDF's capital consists of N stations. The hall is numbered S, while the station numbered T denotes prince' current place. M muddy directed sideways connect some of the stations. Remmarguts' path to welcome the princess might include the same station twice or more than twice, even it is the station with number S or T. Different paths with same length will be considered disparate. 

Input

The first line contains two integer numbers N and M (1 <= N <= 1000, 0 <= M <= 100000). Stations are numbered from 1 to N. Each of the following M lines contains three integer numbers A, B and T (1 <= A, B <= N, 1 <= T <= 100). It shows that there is a directed sideway from A-th station to B-th station with time T. 

The last line consists of three integer numbers S, T and K (1 <= S, T <= N, 1 <= K <= 1000).

Output

A single line consisting of a single integer number: the length (time required) to welcome Princess Uyuw using the K-th shortest path. If K-th shortest path does not exist, you should output "-1" (without quotes) instead.

Sample Input

2 2
1 2 5
2 1 4
1 2 2
      

Sample Output

14      

Source

POJ Monthly,Zeyuan Zhu

第k短路,存圖時,正向反向都存,然後根據反向圖spfa跑一遍,因為之後用A* 做鋪墊,恩,A* ,通過估價函數确定目前點到終點的距離,決定搜尋方向,這裡估價函數=目前值+目前位置到終點的距離,f(p)=h(p)+g(p) ,每次擴充估價函數值最小的一個。對于k 短路, g(p) 為目前從起點到目前點的路徑長度,h(p)為從目前點到終點的最短路的長度(之前spfa求得的距離)

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<queue>
#define maxn 1010
#define inf 0x3f3f3f3f
using namespace std;
int head[maxn],rhead[maxn];
int n,k,s,e,cnt,dis[maxn];
bool vis[maxn];
struct node
{
    int f,t,w,next;
};
struct rnode
{
    int t,g,f;
    bool operator < (const rnode r)const
    {
        if(r.f==f)
            return r.g < g;
        else
            return r.f < f;
    }
};
node edge[maxn*100],redge[maxn*100];
void add(int f,int t,int w)
{
    edge[cnt].f=f;
    edge[cnt].t=t;
    edge[cnt].w=w;
    edge[cnt].next=head[f];
    head[f]=cnt;
    redge[cnt].f=t;
    redge[cnt].t=f;
    redge[cnt].w=w;
    redge[cnt].next=rhead[t];
    rhead[t]=cnt++;
}
bool spfa()
{
    int i,k;
    memset(vis,false,sizeof(vis));
    queue<int>q;
    for(int i=0;i<=n;++i)
        dis[i]=inf;
    vis[e]=true;
    dis[e]=0;
    q.push(e);
    while(!q.empty())
    {
        int v=q.front();
        q.pop();
        vis[v]=false;
        for(int i=rhead[v];i!=-1;i=redge[i].next)
        {
            int u=redge[i].t;
            int w=redge[i].w;
            if(dis[u]>dis[v]+w)
            {
                dis[u]=dis[v]+w;
                if(!vis[u])
                {
                    vis[u]=true;
                    q.push(u);
                }
            }
        }
    }
    return true;
}
int a_star()
{
    rnode now,next;
    int num=0;
    priority_queue<rnode>q;
    if(s==e)
        k++;
    if(dis[s]==inf)
        return -1;
    now.t=s;
    now.g=0;
    now.f=now.g+dis[s];
    q.push(now);
    while(!q.empty())
    {
        now=q.top();
        q.pop();
        if(now.t==e)
            num++;
        if(num==k)
            return now.g;
        for(int i=head[now.t];i!=-1;i=edge[i].next)
        {
            next.t=edge[i].t;
            next.g=now.g+edge[i].w;
            next.f=next.g+dis[next.t];
            q.push(next);
        }
    }
    return -1;
}
int main()
{
    int m,a,b,t;
    while(~scanf("%d%d",&n,&m))
    {
        cnt=0;
        memset(head,-1,sizeof(head));
        memset(rhead,-1,sizeof(rhead));
        for(int i=0;i<m;++i)
        {
            scanf("%d%d%d",&a,&b,&t);
            add(a,b,t);
        }
        scanf("%d%d%d",&s,&e,&k);
        spfa();
        int klength=a_star();
        printf("%d\n",klength);
    }
    return 0;
}
           

繼續閱讀