天天看點

PAT甲級:1124 Raffle for Weibo Followers (20分) 字元串去重

1124 Raffle for Weibo Followers (20分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽獎) for his followers on Weibo – that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John’s post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going… instead.

Sample Input 1:

9 3 2

Imgonnawin!

PickMe

PickMeMeMeee

LookHere

Imgonnawin!

TryAgainAgain

TryAgainAgain

Imgonnawin!

TryAgainAgain

Sample Output 1:

PickMe

Imgonnawin!

TryAgainAgain

Sample Input 2:

2 3 5

Imgonnawin!

PickMe

Sample Output 2:

Keep going…

就是注意點已經獲獎的人再次獲獎直接跳過就行

然後判斷是否重複獲獎我使用的是 unordered_set 的find函數

#include <iostream>
#include <unordered_set>
#include <vector>
//M (≤ 1000), N and S, being the total number of forwards, the skip number of winners,
//and the index of the first winner (the indices start from 1).
//赢過的人就跳過
using namespace std;

int main()
{
    int N,skip,start;
    cin>>N>>skip>>start;
    string strSn[N];
    for(int i=0;i<N;i++){
        cin>>strSn[i];
    }
    unordered_set<string> sett;
    vector<string> vec;
    int i=start-1;

    while(i<N){
        //如果這個人還沒獲獎
        if(sett.find(strSn[i])==sett.end()){
            sett.insert(strSn[i]);
            vec.push_back(strSn[i]);
            i+=skip;
        }
        //獲獎了就是看下一個人是否有資格獲獎了
        else
            i++;

    }
    if(vec.size()==0){
        cout<<"Keep going...";
    }
    else{
        for(int i=0;i<vec.size();i++){
            cout<<vec[i]<<endl;
        }
    }
    return 0;
}

           

繼續閱讀