天天看點

HDU--1008--Elevator

Description

The highestbuilding in our city has only one elevator. A request list is made up with Npositive numbers. The numbers denote at which floors the elevator will stop, inspecified order. It costs 6 seconds to move the elevator up one floor, and 4seconds to move down one floor. The elevator will stay for 5 seconds at eachstop. 

For a given request list, you are to compute the total time spent to fulfillthe requests on the list. The elevator is on the 0th floor at the beginning anddoes not have to return to the ground floor when the requests are fulfilled. 

Input

There are multipletest cases. Each case contains a positive integer N, followed by N positivenumbers. All the numbers in the input are less than 100. A test case with N = 0denotes the end of input. This test case is not to be processed. 

Output

Print the totaltime on a single line for each test case. 

Sample Input

 1 2

3 2 3 1

Sample Output

 17

41

簡單模拟

#include<stdio.h>
int main()
{
	int n;
	int i,f,a[200],s;
	while(scanf("%d",&n)&&n)
	{
		s=0;
		for(i=0;i<n;i++)
		scanf("%d",&a[i]);
		i=0;
		f=0;
		while(n--)
		{
			if(a[i]>f)
			{
				s=s+6*(a[i]-f)+5;
				f=a[i];
			}
			else
			{
				s=s+4*(f-a[i])+5;
				f=a[i];
			}
			i++;
		} 
		printf("%d\n",s);
		}
}