天天看點

CDUESTC 2016 假期賽1 D題

D - An easy problem

Time Limit:3000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

When Teddy was a child , he was always thinking about some simple math problems ,such as “What it’s 1 cup of water plus 1 pile of dough ..” , “100 yuan buy 100 pig” .etc.. 

One day Teddy met a old man in his dream , in that dream the man whose name was“RuLai” gave Teddy a problem : 

Given an N , can you calculate how many ways to write N as i * j + i + j (0 < i <= j) ? 

Teddy found the answer when N was less than 10…but if N get bigger , he found it was too difficult for him to solve. 

Well , you clever ACMers ,could you help little Teddy to solve this problem and let him have a good dream ? 

Input

The first line contain a T(T <= 2000) . followed by T lines ,each line contain an integer N (0<=N <= 10 

10).

Output

For each case, output the number of ways in one line.

Sample Input

2

1

3

Sample Output

此題是一個數學規律題,(其實我一開始也是想暴力的,TLE了兩次,WA了一次,發現必須得用數學公式),不難發現(i+1)*(j+1)=m+1,是以題目變成了求m+1的因數的對數個數

#include <stdio.h>  
#include <math.h>  
int main()  
{  
    int n;
    __int64 m,i,j;  
    scanf("%d",&n);  
    while(n--)  
    {  
        scanf("%I64d",&m);  
        m++;  
        int count = 0;  
        j = sqrt(m);
        for(i = 2;i<=j ; i++)// (i+1)*(j+1) = m+1  
        {  
            if(m % i == 0)  
            count++;  
        }  
        printf("%d\n",count);  
    } 
    return 0; 
}