天天看點

杭電ACM 1005 Number SequenceNumber Sequence

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 38553    Accepted Submission(s): 8150

Problem Description A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).   Input The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.   Output For each test case, print the value of f(n) on a single line.   Sample Input

1 1 3
1 2 10
0 0 0      

  Sample Output

2
5      
苦B了好長時間,終于解決啦。。      
思路:

因為循環的條件就是有2個數m和n

f[m-1] = f[n-1], f[m] = f[n]

這樣就會開始循環了。

即f[n-1], f[n]與之前的[m-1],f[m]分别對應

而 0 <= f[n-1],f[n] < 7

是以f[n-1]f[n]連着的情況有7*7的情況。

隻需每次求出一個f[n],然後比較f[n-1]f[n]與前面數的情況即可。

程式如下:

#include<stdio.h>
int main()
{
     long int a,b,n,T,s[101];
     while(scanf("%ld%ld%ld",&a,&b,&n)&&(a!=0&&b!=0&&n!=0))
     {
        int i,j,T;
        s[0]=1;
        s[1]=1;
        for(i=2;i<101;i++){//第一個循環

            s[i]=(a*s[i-1]+b*s[i-2])%7;
            for(j=1;j<i-1;j++)//第二個循環
            {
                if(s[j-1]==s[i-1]&&s[j]==s[i]){
                    T=i-j;
                    break;
                }
            }
        }
        n = n%T;
        printf("%ld\n",s[n-1]);
     }
     return 0;
}


注意以下幾點:

1.用長整型定義n。

2.找出循環的周期T。我這裡的話,通過兩個來找T,條件是:s[j-1]==s[i-1],s[j]==s[i].
      

繼續閱讀