Binary Tree
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1482 Accepted Submission(s): 880
Special Judge
Problem Description
The Old Frog King lives on the root of an infinite tree. According to the law, each node should connect to exactly two nodes on the next level, forming a full binary tree.
Since the king is professional in math, he sets a number to each node. Specifically, the root of the tree, where the King lives, is 1. Say froot=1.
And for each node u, labels as fu, the left child is fu×2 and right child is fu×2+1. The king looks at his tree kingdom, and feels satisfied.
Time flies, and the frog king gets sick. According to the old dark magic, there is a way for the king to live for another N years, only if he could collect exactly N soul gems.
Initially the king has zero soul gems, and he is now at the root. He will walk down, choosing left or right child to continue. Each time at node x, the number at the node is fx (remember froot=1), he can choose to increase his number of soul gem by fx, or decrease it by fx.
He will walk from the root, visit exactly K nodes (including the root), and do the increasement or decreasement as told. If at last the number is N, then he will succeed.
Noting as the soul gem is some kind of magic, the number of soul gems the king has could be negative.
Given N, K, help the King find a way to collect exactly N soul gems by visiting exactly K nodes.
Input
First line contains an integer T, which indicates the number of test cases.
Every test case contains two integers N and K, which indicates soul gems the frog king want to collect and number of nodes he can visit.
⋅ 1≤T≤100.
⋅ 1≤N≤109.
⋅ N≤2K≤260.
Output
For every test case, you should output "Case #x:" first, where x indicates the case number and counts from 1.
Then K lines follows, each line is formated as 'a b', where a is node label of the node the frog visited, and b is either '+' or '-' which means he increases / decreases his number by a.
It's guaranteed that there are at least one solution and if there are more than one solutions, you can output any of them.
Sample Input
2
5 3
10 4/
Sample Output
Case #1:
1 +
3 -
7 +
Case #2:
1 +
3 +
6 -
12 +
Source
2015ACM/ICPC亞洲區上海站-重制賽(感謝華東理工)
現在想來非常簡單的一道構造題。
大緻題意是給你一棵無窮大的滿二叉樹,其中任意節點i的兩個兒子分别是2*i和2*i+1,然後每個節點的權值等于節點的編号。然後現在給你一個n和k,要你從根節點1開始,一直往下走選取k個節點,然後給每一個選取的點的點權加上正負,最後輸出使得這k個節點的權重和為n的方案。隻要求輸出一種即可。
#include<bits/stdc++.h>
#define INF 0x3f3f3f3f
#define LL long long
#define N 100010
using namespace std;
LL n,m,num[N];
bool sign[N];
int main()
{
int T_T,T;
cin>>T_T;T=0;
while(T_T--)
{
scanf("%I64d%I64d",&n,&m);
LL i,j;
for(i=1,j=1;i<=m;i++,j<<=1)
num[i]=j,sign[i]=1;
LL x=j-1-n;
if (x&1) x++,num[m]++;
x>>=1;
for(;j;j>>=1,i--)
if (x>=j) sign[i]=0,x-=j;
printf("Case #%d:\n",++T);
for(int i=1;i<=m;i++)
printf("%I64d %c\n",num[i],sign[i]?'+':'-');
}
return 0;
}