天天看點

浙大 PAT Advanced level 1025. PAT Ranking (25)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2

5

1234567890001 95

1234567890005 100

1234567890003 95

1234567890002 77

1234567890004 85

4

1234567890013 65

1234567890011 25

1234567890014 100

1234567890012 85

Sample Output:

9

1234567890005 1 1 1

1234567890014 1 2 1

1234567890001 3 1 2

1234567890003 3 1 2

1234567890004 5 1 4

1234567890012 5 2 2

1234567890002 7 1 5

1234567890013 8 2 3

1234567890011 9 2 4

簡單的排序題,記得要使用标準庫的sort。13位的ID既可以用string來記錄,也可以用long long int記錄。

對于排序問題非常重要的一個細節是,輸入中有相同的分數的情況對排名的影響。

如:

ID     score        rank

A       98              1

B       95              2

C       95              2

D      93              4

#include <iostream>
#include <algorithm>
#include <list>
#include <stdio.h>
using namespace std;

typedef struct node
{
	unsigned long long int registration_number;
	unsigned int score;
	unsigned int final_rank;
	unsigned int location_number;
	unsigned int local_rank;
}node;

#if 0
// 每組内比較
bool local_compare(node A, node B)
{
	if (A.location_number == B.location_number)
	{
		if (A.score == B.score)
		{
			return A.registration_number < B.registration_number;
		}
		else
		{
			return A.score < B.score;
		}
	}
	else
	{
		return A.location_number < B.location_number;
	}
}
#endif

// 全部比較
bool global_compare(node &A, node &B)
{
	if (A.score == B.score)
	{
		return A.registration_number < B.registration_number;
	}
	else
	{
		return A.score > B.score;
	}	
}

int main()
{
	int n;
	int items_num; 
	int total_num = 0;
	node ntmp;
	list<node> result;
	list<node> ltmp;
	unsigned int tmpscore = 0xffffffff;
	unsigned int tmprank = 0;
	int index;

	cin >> n;

	for (int location = 1; location <= n; ++location)
	{
		cin >> items_num;
		total_num += items_num;
		while (items_num--)
		{
			cin >> ntmp.registration_number;
			cin >> ntmp.score;
			ntmp.location_number = location;
			ltmp.push_back(ntmp);
		}
		ltmp.sort(global_compare);
		index = 0;
		tmpscore = 0xffffffff;
		for (list<node>::iterator iter = ltmp.begin();
			iter != ltmp.end(); ++iter)
		{
			++index;
			if (0xffffffff == tmpscore)
			{
				iter->local_rank = index;
				tmpscore = iter->score;
				tmprank = iter->local_rank;
			}
			else
			{
				if (tmpscore == iter->score)
				{
					iter->local_rank = tmprank;
				}
				else
				{
					iter->local_rank = index;
					tmpscore = iter->score;
					tmprank = iter->local_rank;
				}
			}
		}
		result.merge(ltmp, global_compare);
		ltmp.clear();
	}
	result.sort(global_compare);
	index = 0;
	tmpscore = 0xffffffff;
	for (list<node>::iterator iter = result.begin(); iter != result.end(); ++iter)
	{
		++index;
		if (0xffffffff == tmpscore)
		{
			iter->final_rank = index;
			tmpscore = iter->score;
			tmprank = iter->final_rank;
		}
		else
		{
			if (tmpscore == iter->score)
			{
				iter->final_rank = tmprank;
			}
			else
			{
				iter->final_rank = index;
				tmpscore = iter->score;
				tmprank = iter->final_rank;
			}
		}
	}

	cout << index << endl;
	for (list<node>::iterator iter = result.begin(); iter != result.end(); ++iter)
	{
		printf("%013lld %d %d %d\n", iter->registration_number, iter->final_rank, iter->location_number, iter->local_rank);
	}

	system("pause");
	return 0;
}