天天看點

HDU 1009.FatMouse' Trade【貪心算法】【8月16】

FatMouse' Trade

Problem Description FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

Output For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
        

Sample Output

13.333
31.500
  
  

        

這個·····貪心不想多說,代碼很簡單:

#include<cstdio>
#include<algorithm>
using namespace std;
struct ss{
    double val,wei,vval;
};
bool cmp(ss x,ss y){
    if(x.vval>y.vval) return true;
    else return false;
}
int main(){
    int n,m;
    while(scanf("%d%d",&m,&n)!=EOF&&(n!=-1&&m!=-1)){
        ss f[1010];
        for(int i=0;i<n;i++){
            scanf("%lf %lf",&f[i].wei,&f[i].val);
            f[i].vval=f[i].wei/f[i].val;
        }
        sort(f,f+n,cmp);
        double Max=0;
        for(int i=0;i<n&&m>0.000001;i++){
            if(m>=f[i].val){
                Max+=f[i].wei;
                m-=f[i].val;
            }
            else{
                Max+=m*f[i].vval;
                m=0;
            }
        }
        printf("%.3f\n",Max);
    }
    return 0;
}