天天看點

[hdu2822]Dogs

Time Limit: 2000/1000 MS (Java/Others)

Memory Limit: 32768/32768 K (Java/Others)

Problem Description

Prairie dog comes again! Someday one little prairie dog Tim wants to visit one of his friends on the farmland, but he is as lazy as his friend (who required Tim to come to his place instead of going to Tim’s), So he turn to you for help to point out how could him dig as less as he could.

We know the farmland is divided into a grid, and some of the lattices form houses, where many little dogs live in. If the lattices connect to each other in any case, they belong to the same house. Then the little Tim start from his home located at (x0, y0) aim at his friend’s home ( x1, y1 ). During the journey, he must walk through a lot of lattices, when in a house he can just walk through without digging, but he must dig some distance to reach another house. The farmland will be as big as 1000 * 1000, and the up left corner is labeled as ( 1, 1 ).

Input

The input is divided into blocks. The first line in each block contains two integers: the length m of the farmland, the width n of the farmland (m, n ≤ 1000). The next lines contain m rows and each row have n letters, with ‘X’ stands for the lattices of house, and ‘.’ stands for the empty land. The following two lines is the start and end places’ coordinates, we guarantee that they are located at ‘X’. There will be a blank line between every test case. The block where both two numbers in the first line are equal to zero denotes the end of the input.

Output

For each case you should just output a line which contains only one integer, which is the number of minimal lattices Tim must dig.

Sample Input

6 6
..X...
XXX.X.
....X.
X.....
X.....
X.X...
3 5
6 3

0 0
           

Sample Output

3
           

#####Hint:

Three lattices Tim should dig: ( 2, 4 ), ( 3, 1 ), ( 6, 2 ).
           

題意:

給一個m*n的平面圖,點上為‘X’的表示可以直接走的通道,點上為‘.’表示要挖開才能走的通道,問最少要挖開多少個通道才能從S點走到T點。S,T在最後給出

題解:

類似求最短路的方法,如果是路徑終點是‘.’則路徑長度為1,路徑終點為‘X’則路徑長度為0,用優先隊列跑一次BFS即可。

#include<bits/stdc++.h>
#define INF 1999122700
#define pa pair<int,int>
#define ppa pair<int,pair<int,int> >
using namespace std;
int m,n;
priority_queue<ppa,vector<ppa>,greater<ppa> >q;
int dx[4]={0,1,0,-1},
    dy[4]={1,0,-1,0};
char mp[1004][1004];
int dis[1004][1004];
int bfs(pa st,pa ed){
    for(int i=1;i<=m;i++)
        for(int j=1;j<=n;j++)
            dis[i][j]=INF;
    while(!q.empty())q.pop();
    q.push(make_pair(0,st));
    dis[st.first][st.second]=0;
    while(!q.empty()){
        int sp=q.top().first;
        pa now=q.top().second;q.pop();
        if(now==ed)return sp;
        for(int i=0;i<4;i++){
            if(now.first+dx[i]<=0||now.first+dx[i]>m||
               now.second+dy[i]<=0||now.second+dy[i]>n)continue;
            pa G;
            G.first=now.first+dx[i];
            G.second=now.second+dy[i];
            int delta=(mp[G.first][G.second]=='.');
            if( dis[G.first][G.second]>sp+delta){
                dis[G.first][G.second]=sp+delta;
                q.push(make_pair(sp+delta,G));
            }
        }
    }
    return INF;
}
int w33ha(){
    int cnt=0;
    for(int i=1;i<=m;i++)scanf("%s",mp[i]+1);
    pa st,ed;
    scanf("%d%d",&st.first,&st.second);
    scanf("%d%d",&ed.first,&ed.second);
    printf("%d\n",bfs(st,ed));
    return 0;
}
int main(){
    while(scanf("%d%d",&m,&n)!=EOF){
        if(n==0&&m==0)break;
        w33ha();
    }
    return 0;
}