天天看點

hdu1013Digital RootsDigital Roots

Digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 91251    Accepted Submission(s): 28397

http://acm.hdu.edu.cn/showproblem.php?pid=1013

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.

Output

For each integer in the input, output its digital root on a separate line of the output.

Sample Input

24

39

Sample Output

6

3

題意:把一個數每位上的數相加,若為個位數輸出,否則重複過程。

代碼:

#include<iostream>
#include<cmath>
#include<cstring>
using namespace std;

int del(int n)
{
    int sum=0;
    while(n)
    {
        sum+=n%10;
        n/=10;
    }
    if(sum>9)
        del(sum);
    else
        return sum;
}

int main()
{
    char s[100005];
    while(cin>>s)
    {
        int n=strlen(s);
        if(s[0]=='0'&&n==1)
            break;
        int sum=0;
        for(int i=0;i<n;i++)
        {
            sum+=s[i]-'0';
        }
        //cout<<sum<<endl;
        if(sum>9)
            cout<<del(sum)<<endl;
        else
            cout<<sum<<endl;
    }
    return 0;
}
           
HDU