天天看點

HDU 1021 Fibonacci Again(找規律) Fibonacci Again

Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 50903    Accepted Submission(s): 24098

Problem Description There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0
1
2
3
4
5
        

Sample Output

no
no
yes
no
no
no
        

Author Leojay

原題連結:http://acm.hdu.edu.cn/showproblem.php?pid=1021

題解:取模的題還是找規律,容易知,此題的結果為以8為周期的序列,通過求出前8個的結果也就知道了結果. 再對結果對3取模後,發現結果也有規律,也是個循環序列,前兩個除外,此時便找到了一個更加好的方法.

AC代碼:

#include<iostream>
using namespace std;
int a[10];
int main()
{
    a[0]=1,a[1]=11;
    int n;
    for(int i=2;i<8;i++)
    {
        a[i]=(a[i-1]+a[i-2]);
    }
    while(cin>>n)
    {
        if((a[n%8])%3==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}
           

AC代碼2(優化版)

#include <iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n)
    {
        if((n+2)%4==0)
            cout<<"yes"<<endl;
        else
            cout<<"no"<<endl;
    }
    return 0;
}