天天看點

1149 Dangerous Goods Packaging (25point(s)) - C語言 PAT 甲級

1149 Dangerous Goods Packaging (25point(s))

When shipping goods with containers, we have to be careful not to pack some incompatible goods into the same container, or we might get ourselves in serious trouble. For example, oxidizing agent (氧化劑) must not be packed with flammable liquid (易燃液體), or it can cause explosion.

Now you are given a long list of incompatible goods, and several lists of goods to be shipped. You are supposed to tell if all the goods in a list can be packed into the same container.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers: N (≤10​4​​), the number of pairs of incompatible goods, and M (≤100), the number of lists of goods to be shipped.

Then two blocks follow. The first block contains N pairs of incompatible goods, each pair occupies a line; and the second one contains M lists of goods to be shipped, each list occupies a line in the following format:

K G[1] G[2] … G[K]

where K (≤1,000) is the number of goods and G[i]'s are the IDs of the goods. To make it simple, each good is represented by a 5-digit ID number. All the numbers in a line are separated by spaces.

Output Specification:

For each shipping list, print in a line Yes if there are no incompatible goods in the list, or No if not.

Sample Input:

6 3

20001 20002

20003 20004

20005 20006

20003 20001

20005 20004

20004 20006

4 00001 20004 00002 20003

5 98823 20002 20003 20006 10010

3 12345 67890 23333

Sample Output:

No

Yes

Yes

題目大意:

1090 危險品裝箱 (25point(s))

設計思路:

1090 危險品裝箱(C語言)

  • 利用二分查找,沒有不相容物品即可裝箱
編譯器:C (gcc)
#include <stdio.h>
#include <stdlib.h>

int cmp(const void *a, const void *b)
{
        return *(int*)a - *(int*)b;
}

int main()
{
        int n, m, k;
        int list[10000][2] = {{0}}, tmp[1000];
        int i, j, f;

        scanf("%d %d", &n, &m);
        for(i = 0; i < n; i++)
                scanf("%d %d", &list[i][0], &list[i][1]);
        for (i = 0; i < m; i++) {
                f = 1;
                scanf("%d", &k);
                for (j = 0; j < k; j++)
                        scanf("%d", tmp + j);

                qsort(tmp, k, sizeof(int), cmp);

                for (j = 0; j < n; j++) {
                        if (bsearch(&list[j][0], tmp, k, sizeof(int), cmp)
                        &&  bsearch(&list[j][1], tmp, k, sizeof(int), cmp)) {
                                puts("No");
                                f = 0;
                                break;
                        }
                }
                if (f)
                        puts("Yes");
        }

        return 0;
}
           

繼續閱讀