天天看點

UVA 1339 Ancient Cipher【水。。。】

1339 - Ancient Cipher

Time limit: 3.000 seconds

Ancient Roman empire had a strong government system with various departments, including a secretservice department. Important documents were sent between provinces and the capital in encryptedform to prevent eavesdropping. The most popular ciphers in those times were so called substitutioncipher and permutation cipher

Substitution cipher changes all occurrences of each letter to some other letter. Substitutes for allletters must be different. For some letters substitute letter may coincide with the original letter. Forexample, applying substitution cipher that changes all letters from ‘A’ to ‘Y’ to the next ones in thealphabet, and changes ‘Z’ to ‘A’, to the message “VICTORIOUS” one gets the message “WJDUPSJPVT”.

Permutation cipher applies some permutation to the letters of the message. For example, applyingthe permutation ⟨2, 1, 5, 4, 3, 7, 6, 10, 9, 8⟩ to the message “VICTORIOUS” one gets the message“IVOTCIRSUO”.

It was quickly noticed that being applied separately, both substitution cipher and permutationcipher were rather weak. But when being combined, they were strong enough for those times. Thus,the most important messages were first encrypted using substitution cipher, and then the result wasencrypted using permutation cipher. Encrypting the message “VICTORIOUS” with the combination ofthe ciphers described above one gets the message “JWPUDJSTVP”.

Archeologists have recently found the message engraved on a stone plate. At the first glance itseemed completely meaningless, so it was suggested that the message was encrypted with some substitutionand permutation ciphers. They have conjectured the possible text of the original message thatwas encrypted, and now they want to check their conjecture. They need a computer program to do it,so you have to write one

Input

Input file contains several test cases. Each of them consists of two lines. The first line contains themessage engraved on the plate. Before encrypting, all spaces and punctuation marks were removed, sothe encrypted message contains only capital letters of the English alphabet. The second line containsthe original message that is conjectured to be encrypted in the message on the first line. It also containsonly capital letters of the English alphabet

The lengths of both lines of the input file are equal and do not exceed 100.

Output

For each test case, print one output line. Output ‘YES’ if the message on the first line of the input filecould be the result of encrypting the message on the second line, or ‘NO’ in the other case.

Sample Input

JWPUDJSTVP

VICTORIOUS

MAMA

ROME

HAHA

HEHE

AAA

AAA

NEERCISTHEBEST

SECRETMESSAGES

Sample Output

YES

NO

YES

YES

NO

題目大意就是說,第一個字元串能否由第二個字元串通過任意調換位置之後再每個對應字母分别向後移任意位得到(每個字母向後移的位數是相同的)例子可看題目描述中給的例子。然後因為可以随意調換位置,那麼字母的順序就不重要了,隻需記錄一下每個字母出現的次數,然後排序比較一下即可。

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define maxn 110
using namespace std;
char s[maxn],t[maxn];
int ss[30],tt[30];
int main()
{
    while(~scanf("%s%s",t,s))
    {
        memset(ss,0,sizeof(ss));
        memset(tt,0,sizeof(tt));
        int lens=strlen(s);
        int lent=strlen(t);
        for(int i=0;i<lens;++i)
            ss[s[i]-'A']++;
        for(int i=0;i<lent;++i)
            tt[t[i]-'A']++;
        sort(ss,ss+26);
        sort(tt,tt+26);
        int flag=1;
        for(int i=0;i<26;++i)
        {
            if(ss[i]!=tt[i])
            {
                flag=0;
                break;
            }
        }
        if(!flag)
            printf("NO\n");
        else
            printf("YES\n");
    }
    return 0;
}