天天看點

HDU1078 FatMouse and Cheese DP(記憶化搜尋) FatMouse and Cheese

FatMouse and Cheese

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11002    Accepted Submission(s): 4671

Problem Description FatMouse has stored some cheese in a city. The city can be considered as a square grid of dimension n: each grid location is labelled (p,q) where 0 <= p < n and 0 <= q < n. At each grid location Fatmouse has hid between 0 and 100 blocks of cheese in a hole. Now he's going to enjoy his favorite food.

FatMouse begins by standing at location (0,0). He eats up the cheese where he stands and then runs either horizontally or vertically to another location. The problem is that there is a super Cat named Top Killer sitting near his hole, so each time he can run at most k locations to get into the hole before being caught by Top Killer. What is worse -- after eating up the cheese at one location, FatMouse gets fatter. So in order to gain enough energy for his next run, he has to run to a location which have more blocks of cheese than those that were at the current hole.

Given n, k, and the number of blocks of cheese at each grid location, compute the maximum amount of cheese FatMouse can eat before being unable to move. 

Input There are several test cases. Each test case consists of 

a line containing two integers between 1 and 100: n and k 

n lines, each with n numbers: the first line contains the number of blocks of cheese at locations (0,0) (0,1) ... (0,n-1); the next line contains the number of blocks of cheese at locations (1,0), (1,1), ... (1,n-1), and so on. 

The input ends with a pair of -1's. 

Output For each test case output in a line the single integer giving the number of blocks of cheese collected. 

Sample Input

3 1
1 2 5
10 11 6
12 12 7
-1 -1
        

Sample Output

37
        

  題意:有個n*n的表格,一隻老鼠開始在(0,0)點,每個點都有一些食物。老鼠每次可以水準或者豎直走最多k步,且下一個點的食物要比這個點的食物多。問老鼠最多能吃多少食物。 解析:因為n是100的範圍,是以直接搜尋會TLE,應該用記憶化搜尋。dp[x][y] = max(dp[tx][ty])+a[x][y],其中(tx, ty)是能從(x, y)到達的下一個點,且如果這個點已經記錄下它的dp值,可以直接用;如果沒有記錄,則從這個點繼續往下搜尋。 代碼:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define N 105
int a[N][N], dp[N][N];
int n, k;
int Next[4][2] = {{1,0}, {0,1}, {-1,0}, {0,-1}};
int dfs(int x, int y){
	if(dp[x][y] != -1) return dp[x][y];
	int Max = 0;
	for(int i = 1; i <= k; i++){
		for(int j = 0; j < 4; j++){
			int tx = x + Next[j][0]*i;
			int ty = y + Next[j][1]*i;
			if(tx < 0 || tx >= n || ty < 0 || ty >= n || a[tx][ty] <= a[x][y])continue;
			Max = max(Max, dfs(tx, ty));
		}
	}
	return dp[x][y] = Max + a[x][y];	
}
int main(){
	while(scanf("%d%d", &n, &k) && n+k!=-2){
		for(int i = 0; i < n; i++)
			for(int j = 0; j < n; j++){
				scanf("%d", &a[i][j]);
				dp[i][j] = -1;
			}
		int ans = dfs(0, 0);
		printf("%d\n", ans);
	}
	return 0;
}
           

繼續閱讀