天天看點

HDU_1050 Moving Tables 【貪心】題目資訊: Moving Tables解題思路:代碼如下:

題目資訊:

Moving Tables

Problem Description The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 

HDU_1050 Moving Tables 【貪心】題目資訊: Moving Tables解題思路:代碼如下:

The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 

HDU_1050 Moving Tables 【貪心】題目資訊: Moving Tables解題思路:代碼如下:

For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem.

Input The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above.

Output The output should contain the minimum time in minutes to complete the moving, one per line.

Sample Input

3 
4 
10 20 
30 40 
50 60 
70 80 
2 
1 3 
2 200 
3 
10 100 
20 80 
30 50 
         

Sample Output

10
20
30
   
   

         

解題思路:

題目意思是說要講桌子從一個房間搬到另一個房間,但是因為走廊過窄,僅僅可以容納一個桌子,給多組資料問最少可以消耗多少時間把桌子都搬完,也就是來判斷區間的使用重疊次數。但是有一個細節就是标記數組必須是以走廊為标記及标記數組大小為200而不是以房間為标記數組。(房間1,2都是走廊下标為1)。把測試資料的區間在标記數組上加一,最後求标記數組上大于1的區間個數即可,這裡要注意區間如果大于二,需要加上該區間的最大值。

代碼如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <set>
#include <algorithm>
#include <map>
using namespace std;
int change(int n)//将房間換成走廊區間
{
    if(n%2==0)
        return n/2;
    else
        return(n+1)/2;
}
int main()
{
    int vis[205];
    int T;
    cin>>T;
    while(T--)
    {
        int n,i,j,s,e,t;
        cin>>n;
        memset(vis,0,sizeof(vis));
        for(i=1;i<=n;i++)
        {
            cin>>s>>e;
            if(s>e)
            {
                t=s;
                s=e;
                e=t;
            }
            for(j=change(s);j<=change(e);j++)
                vis[j]++;
        }
        int flag=0,Max=0;
        int ans=0;
        for(i=1;i<=200;i++)
        {
            if(vis[i]>1)
                flag=1;
            if(flag==1&&vis[i]>1)
            {
                if(vis[i]>Max)
                    Max=vis[i];
            }
            if(vis[i]<=1)
            {
                flag=0;
                if(Max==0)
                    continue;
                ans+=Max-1;
                Max=0;
            }
        }
        cout<<(ans+1)*10<<endl;
    }
    return 0;
}