天天看點

HDU 1754 I Hate It【線段樹入門題,單點替換,區間最值】 I Hate It

I Hate It

Time Limit: 9000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 63120    Accepted Submission(s): 24509

Problem Description 很多學校流行一種比較的習慣。老師們很喜歡詢問,從某某到某某當中,分數最高的是多少。

這讓很多學生很反感。

不管你喜不喜歡,現在需要你做的是,就是按照老師的要求,寫一個程式,模拟老師的詢問。當然,老師有時候需要更新某位同學的成績。  

Input 本題目包含多組測試,請處理到檔案結束。

在每個測試的第一行,有兩個正整數 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表學生的數目和操作的數目。

學生ID編号分别從1編到N。

第二行包含N個整數,代表這N個學生的初始成績,其中第i個數代表ID為i的學生的成績。

接下來有M行。每一行有一個字元 C (隻取'Q'或'U') ,和兩個正整數A,B。

當C為'Q'的時候,表示這是一條詢問操作,它詢問ID從A到B(包括A,B)的學生當中,成績最高的是多少。

當C為'U'的時候,表示這是一條更新操作,要求把ID為A的學生的成績更改為B。

Output 對于每一次詢問操作,在一行裡面輸出最高成績。  

Sample Input

5 6
1 2 3 4 5
Q 1 5
U 3 6
Q 3 4
Q 4 5
U 2 9
Q 1 5
        

Sample Output

5
6
5
9


   
    
     Hint
    Huge input,the C function scanf() will work better than cin
   
    
        

Author linle  

Source 2007省賽集訓隊練習賽(6)_linle專場

原題連結: http://acm.hdu.edu.cn/showproblem.php?pid=1754

簡單線段樹,單點替換,區間最值,入門題,模闆題。

AC代碼

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn=200000+5;
using namespace std;
int a[maxn*4];
const int INF=0x3f3f3f3f;
void PushUp(int i)
{
    a[i]=max(a[i*2],a[i*2+1]);
}
void build(int i,int l,int r)
{
    if(l==r)
    {
        scanf("%d",&a[i]);
        return;
    }
    int m=(l+r)/2;
    build(i*2,l,m);
    build(i*2+1,m+1,r);
    PushUp(i);
}
int query(int ql,int qr,int i,int l,int r)
{
    if(ql<=l&&r<=qr)
        return a[i];
    int m=(l+r)/2;
    int maxx=-INF;
    if(ql<=m)
        maxx=max(maxx,query(ql,qr,i*2,l,m));
    if(qr>m)
        maxx=max(maxx,query(ql,qr,i*2+1,m+1,r));
    return maxx;
}
void update(int id,int val,int i,int l,int r)
{
    if(l==r)
    {
        a[i]=val;
        return;
    }
    int m=(l+r)/2;
    if(id<=m)
        update(id,val,i*2,l,m);
    else
        update(id,val,i*2+1,m+1,r);
    PushUp(i);
}
int main()
{
    int n,m;
    char str[10];
    int x,y;
    while(cin>>n>>m)
    {
        build(1,1,n);
        while(m--)
        {
            scanf("%s%d%d",str,&x,&y);
            if(str[0]=='Q')
                printf("%d\n",query(x,y,1,1,n));
            else
                update(x,y,1,1,n);
        }
    }
    return 0;
}