天天看點

HDU 1394(最小逆序數)【也可用線段樹求解】Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 753    Accepted Submission(s): 402

Problem Description The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)

a2, a3, ..., an, a1 (where m = 1)

a3, a4, ..., an, a1, a2 (where m = 2)

...

an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2
        

Sample Output

16
  
  
   先說一下逆序數的概念:
在一個排列中,如果一對數的前後位置與大小順序相反,即前面的數大于後面的數,那末它們就稱為一個逆序。
一個排列中逆序的總數就稱為這個排列的逆序數。逆序數為偶數的排列稱為偶排列;逆序數為奇數的排列稱為奇排列。
如2431中,21,43,41,31是逆序,逆序數是4,為偶排列。
  
  
  
  
  
   思路:每次把末尾的數掉到序列前面時,減少的逆序對數為n-1-a[i] ,
  
  
   增加的逆序對數為a[i] ,
   這樣就可在所有的序列中找出含有逆序對最少的了!
  
  
  
   #include <iostream>
using namespace std;
#define N 5005

int main()
{
	int a[N];
	int n,sum,i,j,min;
	while(scanf("%d",&n)!=EOF)
	{
		sum=0;
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		for(i=1;i<n;i++)
		{
			for(j=i+1;j<=n;j++)
			{
				if(a[i]>a[j])
					sum++;
			}
		}
		min=sum;
		for(i=n;i>=1;i--)
		{
			sum-=n-1-a[i];
			sum+=a[i];
			if(min>sum)
				min=sum;
		}
		printf("%d/n",min);
	}
	return 0;
} 
        

繼續閱讀