Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17320 Accepted Submission(s): 7056
Problem Description There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:
(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
Input The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
Output The output should contain the minimum setup time in minutes, one per line.
Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1
Sample Output
2
1
3
題意:1,第一根木棍設定時間是1min, 2,之後處理的木棍的長度為l,權重為w,如果l1<=l,w1<=w,就不用設定時間,否則就要1min的設定時間。 求最小設定時間 題解:貪心,先根據l從小到大排序,注意,當l相同時,再根據w從小到大排序。
AC代碼:
#include<iostream>
#include<cstdlib>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<string>
#include<cstdlib>
#include<iomanip>
#include<algorithm>
typedef long long LL;
using namespace std;
struct ac{
int l,w;
int flag;
}node[5005];
int cmp(ac a,ac b){
return a.l<b.l||a.l==b.l&&a.w<b.w;
}
int main()
{
int n,i,j,count,k,t;
while(cin>>t){
while(t--){
count=0;
for( i=0;i<5005;i++)
node[i].flag=0;
cin>>n;
for(i=0;i<n;i++){
cin>>node[i].l;
cin>>node[i].w;
}
sort(node,node+n,cmp);
for(i=0;i<n;i++){ //貪心
if(node[i].flag==1)continue;
count++;
k=i;
for(j=i+1;j<n;j++){
if(node[j].l>=node[k].l&&node[j].w>=node[k].w&&node[j].flag==0)
{
node[j].flag=1;
k=j;
}
}
}
printf("%d\n",count);
}
}
return 0;
}