Six Degrees of Cowvin Bacon
Time Limit: 1000MS | Memory Limit: 65536K |
Total Submissions: 3993 | Accepted: 1876 |
Description
The cows have been making movies lately, so they are ready to play a variant of the famous game "Six Degrees of Kevin Bacon".
The game works like this: each cow is considered to be zero degrees of separation (degrees) away from herself. If two distinct cows have been in a movie together, each is considered to be one 'degree' away from the other. If a two cows have never worked together but have both worked with a third cow, they are considered to be two 'degrees' away from each other (counted as: one degree to the cow they've worked with and one more to the other cow). This scales to the general case.
The N (2 <= N <= 300) cows are interested in figuring out which cow has the smallest average degree of separation from all the other cows. excluding herself of course. The cows have made M (1 <= M <= 10000) movies and it is guaranteed that some relationship path exists between every pair of cows.
Input
* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each input line contains a set of two or more space-separated integers that describes the cows appearing in a single movie. The first integer is the number of cows participating in the described movie, (e.g., Mi); the subsequent Mi integers tell which cows were.
Output
* Line 1: A single integer that is 100 times the shortest mean degree of separation of any of the cows.
Sample Input
4 2
3 1 2 3
2 3 4
Sample Output
100
Hint
[Cow 3 has worked with all the other cows and thus has degrees of separation: 1, 1, and 1 -- a mean of 1.00 .]
題意:如果兩頭牛在同一部電影中出現過,那麼這兩頭牛的度就為1, 如果這兩頭牛a,b沒有在同一部電影中出現過,但a,b分别與c在同一部電影中出現過,那麼a,b的度為2。以此類推,a與b之間有n頭媒介牛,那麼a,b的度為n+1。 給出m部電影,每一部給出牛的個數,和牛的編号。問那一頭到其他每頭牛的度數平均值最小,輸出最小平均值乘100。
題解:到所有牛的度數的平均值最小,也就是到所有牛的度數總和最小。那麼就是找這頭牛到其他每頭牛的最小度,也就是最短路徑,相加再除以(n-1)就是最小平均值。對于如何确定這頭牛,我們可以枚舉,最後記錄最下平均值即可。
代碼如下:
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f
int map[310][310],dis[310];
int a[310];
int n;
void dijkstra(int x)
{
int visit[310];
int i,j,min,next=0;
memset(visit,0,sizeof(visit));
for(i=1;i<=n;++i)
{
dis[i]=map[x][i];
}
visit[x]=1;
for(i=2;i<=n;++i)
{
min=INF;
for(j=1;j<=n;++j)
{
if(!visit[j]&&min>dis[j])
{
next=j;
min=dis[j];
}
}
visit[next]=1;
for(j=1;j<=n;++j)
{
if(!visit[j]&&dis[j]>dis[next]+map[next][j])
dis[j]=dis[next]+map[next][j];
}
}
}
int main()
{
int m,i,num,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;++i)
{
for(j=1;j<=n;++j)
{
if(i==j)
map[i][j]=0;
else
map[i][j]=map[j][i]=INF;//初始化一定要為極大值
}
}
while(m--)
{
scanf("%d",&num);
for(i=0;i<num;++i)
scanf("%d",&a[i]);
for(i=0;i<num;++i)
{
for(j=0;j<num;++j)
{
if(a[i]!=a[j])
map[a[i]][a[j]]=map[a[j]][a[i]]=1;
}
}
}
double ans=INF;
for(i=1;i<=n;++i)//枚舉每一頭牛
{
double sum=0;
dijkstra(i);
for(j=1;j<=n;++j)//記錄到其他牛的度數之和
{
if(i!=j)
sum+=dis[j];
}
ans=min(ans,sum*1.0/(n-1));
}
printf("%d\n",(int)(ans*100));
}
return 0;
}