天天看點

杭電oj 1008Elevator



Elevator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 57269    Accepted Submission(s): 31347

Problem Description The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0
        

Sample Output

17
41
        

 很簡單的題目,需要注意的是,若兩次在同一層也要算時間, 我的代碼

#include <iostream>
using namespace std;
int main()
{
	int number;
	int preFloor;
	int nowFloor;
	int time;
	int i;
	while(cin>>number&&number)
	{
		preFloor=0;
		time=0;
		for(i=0;i<number;i++)
		{
			cin>>nowFloor;
			if(nowFloor>preFloor)
			{
				time=time+5+(nowFloor-preFloor)*6;
			}
			else
			{
				time=time+5+(preFloor-nowFloor)*4;
			}
			preFloor=nowFloor;
		}
		cout<<time<<endl;
	}
	return 0;
}