天天看點

HUD6441——Find Integer

Find Integer

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 1391 Accepted Submission(s): 443

Special Judge

Problem Description

people in USSS love math very much, and there is a famous math problem .

give you two integers n,a,you are required to find 2 integers b,c such that an+bn=c^n.

Input

one line contains one integer T;(1≤T≤1000000)

next T lines contains two integers n,a;(0≤n≤1000,000,000,3≤a≤40000)

Output

print two integers b,c if b,c exits;(1≤b,c≤1000,000,000);

else print two integers -1 -1 instead.

Sample Input

1

2 3

Sample Output

4 5

**提示:**費馬定理——當整數 n> 2 時,關于 x,y,z 的方程 x^n + y^n = z^n 沒有正整數解,注意不能用過多檔案頭和萬能檔案頭會逾時

HUD6441——Find Integer

AC代碼:

#include <stdio.h>
long long int n,a,b,c,z;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld %lld",&n,&a);
        if(n==2)
        {
            z=a*a;
            if(a%2)  //a為奇數
            {
                b=z/2;
                c=z/2+1;
            }
            else     //a為偶數
            {
                b=z/4-1;
                c=z/4+1;
            }
            printf("%lld %lld\n",b,c);
        }
        else if(n==1)
            printf("1 %lld\n",a+1);
        else
            printf("-1 -1\n");
    }
    return 0;
}



           

餘生還請多多指教!