天天看點

How Many Trees?推導公式:h(n)=h(n-1)*(4*n-2)/(n+1);

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 

Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set. 

Output

You have to print a line in the output for each entry with the answer to the previous question. 

Sample Input

1
2
3
           

Sample Output

1
2
5
           

推導公式:h(n)=h(n-1)*(4*n-2)/(n+1);

将數字一個一個存入數組

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int a[110][110];    //大數卡特蘭數
int b[110];         //卡特蘭數的長度 

void Catalan(){     //求卡特蘭數
    int i,j,len,carry,tmp;
    a[1][0]=b[1]=1;
    len=1;
    for(i=2;i<=100;i++){
        for(j=0;j<len;j++)      //乘法 
            a[i][j]=a[i-1][j]*(4*i-2);
        carry=0;
        for(j=0;j<len;j++){     //處理相乘結果
            tmp=carry+a[i][j];
            a[i][j]=tmp%10;
            carry=tmp/10;
        }
        while(carry){       //進位處理 
            a[i][len++]=carry%10;    //一個一個存入數組直到carry=0
            carry/=10;
        }
   
        for(j=len-1;j>=0;j--){  //除法 
            tmp=carry*10+a[i][j];
            a[i][j]=tmp/(i+1);
            carry=tmp%(i+1);
        }   
        while(!a[i][len-1])     //高位零處理
            len--;
        b[i]=len;
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    int n;
    Catalan();
    while(~scanf("%d",&n)){
        for(int i=b[n]-1;i>=0;i--)
            printf("%d",a[n][i]);
        printf("\n");
    }
    return 0;
}
           

繼續閱讀