天天看點

hdu 1159Common Subsequence(dp 最大不連續的子序列)Common Subsequence

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 32764    Accepted Submission(s): 14828

Problem Description A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y. 

The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line. 

Sample Input

abcfbc abfcab
programming contest 
abcd mnp
        

Sample Output

4
2
0
        

Source Southeastern Europe 2003   

Recommend Ignatius

 設序列X={x1,x2,…,xm}和Y={y1,y2,…,yn}的最長公共子序列為Z={z1,z2,…,zk} ,則

(1)若xm=yn,則zk=xm=yn,且zk-1是xm-1和yn-1的最長公共子序列。

(2)若xm≠yn且zk≠xm,則Z是xm-1和Y的最長公共子序列。

(3)若xm≠yn且zk≠yn,則Z是X和yn-1的最長公共子序列。

dp[i][j]  表示i到j的最長序列長度

當str1==str2 dp[i][j]=dp[i-1][j-1]+1

 當str1!=str2  dp[i][j]在dp[i-1][j],dp[i][j-1]取一個最大值 

#include<iostream>
#include<cstring>
#include<string>
using namespace std;
string a,b;
int c[1001][1001];
int main()
{

	int n,m,k,i,j;
	while(cin>>a>>b)
	{
			memset(c,0,sizeof(c));
		n=a.size();
		m=b.size();
		for(i=1;i<=n;i++)
		{
			for(j=1;j<=m;j++)
			{
				if(a[i-1]==b[j-1])
				{
					c[i][j]=c[i-1][j-1]+1;
				}
				else c[i][j]=max(c[i-1][j],c[i][j-1]);
			}
		}
		cout<<c[n][m]<<endl;
	}	
} 
           

繼續閱讀