天天看點

2017CCPC網絡選拔賽 1003-Friend-GraphFriend-Graph

Friend-Graph

                                                  Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

                                                                          Total Submission(s): 6514    Accepted Submission(s): 1610

Problem Description

It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team.

In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team.

A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

Input

The first line of the input gives the number of test cases T; T test cases follow.(T<=15)

The first line od each case should contain one integers n, representing the number of people of the team.( n≤3000 )

Then there are n-1 rows. The i th row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

Output

Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

Sample Input

1
4
1 1 0
0 0
1
        

Sample Output

Great Team!
        

用到的 是 六度分離理論:世界上任意六個人中,一定有三個人互相認識,或三個人互相不認識,或者參考 百度百科:六度分離理論

注意,這道題目裡面, 朋友的朋友不是朋友!!!

代碼:

#include <cstdio>
#include <cstring>
#define maxn 6  //隻考慮 n= 3,4,5 的情況即可,暴力
using namespace std;

int a[maxn][maxn];  //鄰接矩陣 存儲無向圖
int main()
{
    int T,n;
    scanf("%d",&T);
    while(T--)
    {
        int flag=0;
        scanf("%d",&n);
        if(n>=6)
            flag=1;
        if(n==1 || n==2)
            flag=2;

        memset(a,0,sizeof a);
        int value;
        for(int i=1;i<=n-1;i++) {
            for(int j=1;j<=n-i;j++)
            {
                scanf("%d",&value);
                a[i][i+j]=1;
                a[j+i][i]=1;
            }
        }
        if(flag == 2)
            printf("Great Team!\n");
        else if(flag == 1)
            printf("Bad Team!\n");
        else if(flag == 0){
            for(int i=1;i<=n;i++) {
               for(int j=1;j<=n;j++) {
                  for(int k=1;k<=n;k++)
                  {
                      if(i==k || i==j || j==k)
                        continue;
                      //下面是 符合題目中說的, Bad 的兩種情況
                      if(a[i][j]==1&&a[i][k]==1&&a[j][k]==1)  {  flag=1; break;  }
                      if(a[i][j]==0&&a[i][k]==0&&a[j][k]==0)  {  flag=1; break;  }
                  }
                  if(flag) break;
                }
                if(flag) break;
            }
            if(flag == 1)  printf("Great Team!\n");
            else    printf("Bad Team!\n");
        }
    }
    return 0;
}
           

繼續閱讀