天天看點

[ACM - 數論]Eddy's digital Roots(九餘數定理) Eddy's digital Roots

Eddy's digital Roots

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 11   Accepted Submission(s) : 7

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.

Input

The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output

Output n^n's digital root on a separate line of the output.

Sample Input

2
4
0
      

Sample Output

4
4
      

Author

eddy

解題思路:

九餘數的定理:一個數對9取餘等于這個數各位數相加的和對9取餘,例如  123 %9 = (1+2+3)%9,是以題目中要求把一個數的各個位加起來直到是個不大于9的數,就等于直接對這個數對9取餘。比如 789  7+8+9=24   2+4=6     789%9=6 ,  另外公式 比如4的4次方最後對9取餘 等于 {  [(4*4)%9]*4%9}*4%9  。

代碼:

#include <iostream>
using namespace std;
int main()
{
    int n;
    while(cin>>n&&n)
    {
        int i;
        int temp=n;
        for(i=2;i<=n;i++)
            temp=temp*n%9;
        if(temp==0)
            cout<<9<<endl;
        else
            cout<<temp<<endl;
    }
}
           

運作截圖:

[ACM - 數論]Eddy's digital Roots(九餘數定理) Eddy's digital Roots