天天看點

hdu 1163 Eddy's digital Roots (數根)Eddy's digital Roots

Eddy's digital Roots

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3351    Accepted Submission(s): 1897

Problem Description The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.

The Eddy's easy problem is that : give you the n,want you to find the n^n's digital Roots.

Input The input file will contain a list of positive integers n, one per line. The end of the input will be indicated by an integer value of zero. Notice:For each integer in the input n(n<10000).

Output Output n^n's digital root on a separate line of the output.

Sample Input

2
4
0
        

Sample Output

4
4
        

Author eddy  

Recommend JGShining  

題解:這是一道經典的數根問題,首先要知道一個數論知識點,一個非零n進制數mod(n-1)的結果,若為0修正為n-1,這個結果和原來數的數根一樣,證明略。

知道上述結論這道題目就很好做了,AC代碼如下(c語言):

//不用快速幂的代碼
#include <stdio.h>
#include <stdlib.h>
int main()
{
    int n,i,res,mul;

    while(scanf("%d",&n),n)
    {
        for(i=0,res=1,mul=n%9;i<n;i++)
            res=mul*res%9;
        res=res==0?9:res;
        printf("%d\n",res);
    }
    return 0;
}

//用快速幂的代碼,由于n很小,不用都能過
#include <stdio.h>
#include <stdlib.h>
int POW(int a,int b)
{
    int res=1,mul=a;
    while(b)
    {
        if(b&1) res=mul*res%9;
        mul=mul*mul%9;
        b=b>>1;
    }
    return res;
}
int main()
{
    int n,res,m;

    while(scanf("%d%d",&n,&m),n&&m)
    {
        res=POW(n,m);
        res=res==0?9:res;
        printf("%d\n",res);
    }

    return 0;
}