天天看點

hdu——1541Stars(樹狀數組)Stars

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7522    Accepted Submission(s): 2958

Problem Description Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.

hdu——1541Stars(樹狀數組)Stars

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.  

Input The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.  

Output The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.  

Sample Input

5
1 1
5 1
7 1
3 3
5 5
        

Sample Output

1
2
1
1
0
        

Source Ural Collegiate Programming Contest 1999  

Recommend LL

樹狀數組是從1開始的 當x=0時會出現問題 是以進行一步x+1将數組平移 但不影響結果  是按照y值排序  即使x相同但是tree【x】的大小不一樣

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
long long nn[33000],mm[33000];
long long lowbit(long long n)
{
	return n&-n;
}
void update(long long n,long long m)
{
	while(n<32200)
	{
		nn[n]+=m;
		n+=lowbit(n);
	}
}
long long getsum(long long n)
{	
	long long sum=0;
	while(n>0)
	{
		sum+=nn[n];
		n-=lowbit(n);	
	}//當n==6時 sum!=nn【6】的值 sum=sum(6)+sum(4)  sum==1  是以mm[6]=1;就是算出前n項的和
	return sum;
}
int main()
{
	long long n,m,i,k;
	while(cin>>k)
	{
		memset(nn,0,sizeof(nn));
		memset(mm,0,sizeof(mm));
		for(i=1;i<=k;i++)
		{
			cin>>n>>m;
			mm[getsum(n+1)]++;
			update(n+1,1);
		}
		for(i=0;i<k;i++)
		{
			cout<<mm[i]<<endl;
		}	
	}
	return 0;
}
           

繼續閱讀