天天看點

HDU 3974 Assign the task(線段樹 單點更新+lazy)

Problem Description There is a company that has N employees(numbered from 1 to N),every employee in the company has a immediate boss (except for the leader of whole company).If you are the immediate boss of someone,that person is your subordinate, and all his subordinates are your subordinates as well. If you are nobody's boss, then you have no subordinates,the employee who has no immediate boss is the leader of whole company.So it means the N employees form a tree.

The company usually assigns some tasks to some employees to finish.When a task is assigned to someone,He/She will assigned it to all his/her subordinates.In other words,the person and all his/her subordinates received a task in the same time. Furthermore,whenever a employee received a task,he/she will stop the current task(if he/she has) and start the new one.

Write a program that will help in figuring out some employee’s current task after the company assign some tasks to some employee.  

Input The first line contains a single positive integer T( T <= 10 ), indicates the number of test cases.

For each test case:

The first line contains an integer N (N ≤ 50,000) , which is the number of the employees.

The following N - 1 lines each contain two integers u and v, which means the employee v is the immediate boss of employee u(1<=u,v<=N).

The next line contains an integer M (M ≤ 50,000).

The following M lines each contain a message which is either

"C x" which means an inquiry for the current task of employee x

or

"T x y"which means the company assign task y to employee x.

(1<=x<=N,0<=y<=10^9)  

Output For each test case, print the test case number (beginning with 1) in the first line and then for every inquiry, output the correspond answer per line.  

Sample Input

1 
5 
4 3 
3 2 
1 3 
5 2 
5 
C 3 
T 2 1
 C 3 
T 3 2 
C 3
        

Sample Output

Case #1:
-1 
1 
2
        

Source

題意:先輸入n個人,然後是n個人的關系(下屬 上司),然後配置設定任務,每一個上司分到一個任務就把任務給他的所有下屬做,即她的下屬的任務都是這個任務,任務不會平分,

查詢一個人該時刻做的任務

思路:先找到樹根,然後dfs求出每一個人控制的編号,然後每次查詢時查詢該人控制的下屬範圍,然後就是lazy,記錄該人的任務是否已經傳遞下去了

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<queue>
#include<stack>
#include<vector>
#include<set>
#include<map>


#define L(x) (x<<1)
#define R(x) (x<<1|1)
#define MID(x,y) ((x+y)>>1)

#define eps 1e-8
typedef __int64 ll;

#define fre(i,a,b)  for(i = a; i <b; i++)
#define free(i,b,a) for(i = b; i >= a;i--)
#define mem(t, v)   memset ((t) , v, sizeof(t))
#define ssf(n)      scanf("%s", n)
#define sf(n)       scanf("%d", &n)
#define sff(a,b)    scanf("%d %d", &a, &b)
#define sfff(a,b,c) scanf("%d %d %d", &a, &b, &c)
#define pf          printf
#define bug         pf("Hi\n")

using namespace std;

#define INF 0x3f3f3f3f
#define N 50005

int father[N],num;
vector<int>g[N];

int le[N],ri[N];

struct stud{
int le,ri;
int va;
int lazy;
}f[N*4];

int cha(int x)
{
	if(x!=father[x])
		father[x]=cha(father[x]);
	return father[x];
}

void dfs(int x)
{
    int i;
	le[x]=++num;

	fre(i,0,g[x].size())
	{
		dfs(g[x][i]);
	}
    ri[x]=num;
}

void pushdown(int pos)
{
	if(f[pos].va==-1) return ;
	if(f[pos].lazy==0) return ;

	f[L(pos)].va=f[pos].va;
	f[R(pos)].va=f[pos].va;
	f[L(pos)].lazy=f[R(pos)].lazy=1;
    f[pos].lazy=0;
}

void build(int pos,int le,int ri)
{
	f[pos].le=le;
	f[pos].ri=ri;
	f[pos].lazy=0;
	f[pos].va=-1;
	if(le==ri) return ;

	int mid=MID(le,ri);

	build(L(pos),le,mid);
	build(R(pos),mid+1,ri);
}

void update(int pos,int le,int ri,int va)
{
	if(f[pos].le==le&&f[pos].ri==ri)
	{
		f[pos].va=va;
		f[pos].lazy=1;
		return ;
	}

    pushdown(pos);

    int mid=MID(f[pos].le,f[pos].ri);

    if(mid>=ri)
		update(L(pos),le,ri,va);
	else
	 if(mid<le)
		update(R(pos),le,ri,va);
	else
	{
		update(L(pos),le,mid,va);
		update(R(pos),mid+1,ri,va);
	}
}

int query(int pos,int le)
{
	if(f[pos].le==le&&f[pos].ri==le)
		return f[pos].va;

	pushdown(pos);

	int mid=MID(f[pos].le,f[pos].ri);

	if(mid>=le)
		return query(L(pos),le);
    return query(R(pos),le);
}


int main()
{
	int i,j,t,m,n,ca=0;
	sf(t);
	while(t--)
	{
		sf(n);
		fre(i,1,n+1)
		{
			father[i]=i;
			g[i].clear();
		}
        int u,v;
        m=n-1;
        while(m--)
		{
			sff(u,v);
			father[u]=v;
			g[v].push_back(u);
		}

       u=cha(1);
       num=0;

       dfs(u);


       build(1,1,num);

       sf(m);

       pf("Case #%d:\n",++ca);

       char op[10];

       while(m--)
	   {
	   	  scanf("%s",op);
	   	  if(op[0]=='C')
		  {
		  	sf(u);
		  	pf("%d\n",query(1,le[u]));
		  }
          else
		  {
		  	 sff(u,v);
		  	 update(1,le[u],ri[u],v);
		  }
	   }
	}
	return 0;
}